aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/fast5/fast5-0.6.4.ebuild')
-rw-r--r--sci-libs/fast5/fast5-0.6.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sci-libs/fast5/fast5-0.6.4.ebuild b/sci-libs/fast5/fast5-0.6.4.ebuild
deleted file mode 100644
index 181c2e593..000000000
--- a/sci-libs/fast5/fast5-0.6.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1 multilib
-
-DESCRIPTION="C++ header-only library for reading Oxford Nanopore Fast5 files"
-HOMEPAGE="https://github.com/mateidavid/fast5"
-SRC_URI="https://github.com/mateidavid/fast5/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="" # the install step is broken (python modules integration, upstream binary code)
-IUSE=""
-
-DEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- sci-libs/hdf5"
-# TODO: more deps
-# https://github.com/mateidavid/tclap.git
-# https://github.com/mateidavid/hpptools.git
-RDEPEND="${DEPEND}"
-
-src_compile(){
- emake -C python develop-user HDF5_DIR="${EPREFIX}"/usr HDF5_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
-}
-
-src_install(){
- dobin src/hufftk
- insinto /usr/include
- doins src/*.hpp
- dobin python/bin/* # bindled binaries
- dolib python/fast5.so # bundled library
-}
-
-python_install_all() {
- cd python || die
- distutils-r1_src_install_all
-}