aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/flexiblas/flexiblas-9999.ebuild')
-rw-r--r--sci-libs/flexiblas/flexiblas-9999.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sci-libs/flexiblas/flexiblas-9999.ebuild b/sci-libs/flexiblas/flexiblas-9999.ebuild
deleted file mode 100644
index 7a7e253d0..000000000
--- a/sci-libs/flexiblas/flexiblas-9999.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit cmake python-any-r1
-
-DESCRIPTION="BLAS/LAPACK wrapper library for runtime switching of backends"
-HOMEPAGE="https://www.mpi-magdeburg.mpg.de/projects/flexiblas"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mpimd-csc/flexiblas"
-else
- SRC_URI="https://github.com/mpimd-csc/flexiblas/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3 MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? ( ${PYTHON_DEPS} )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DTESTS=$(usex test)
- -DEXAMPLES=OFF
- -DCBLAS=ON
- -DLAPACK=ON
- -DBLAS_AUTO_DETECT=OFF
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- dosym libflexiblas.so "/usr/$(get_libdir)/libblas.so"
- dosym libflexiblas.so "/usr/$(get_libdir)/libcblas.so"
- dosym libflexiblas.so "/usr/$(get_libdir)/liblapack.so"
-}