aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gvar')
-rw-r--r--sci-libs/gvar/Manifest1
-rw-r--r--sci-libs/gvar/gvar-13.0.2.ebuild22
-rw-r--r--sci-libs/gvar/metadata.xml19
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/gvar/Manifest b/sci-libs/gvar/Manifest
new file mode 100644
index 000000000..16bdf1de2
--- /dev/null
+++ b/sci-libs/gvar/Manifest
@@ -0,0 +1 @@
+DIST gvar-13.0.2.tar.gz 1001282 BLAKE2B 5c4032406e3d514351bac6f21b5353c8db4e2081efd26b758cce126cce4a3df350ac8086e89895c73ffc27367773a43354138e8598490cbe8f7bacdde216f0bd SHA512 541cb5cc44909cf44e9f808a08a959aa5e3e91c49356fb8865879a9dbb5fe6f3c4b46d88bc4f9346d9b83163c938dfd697e73b7b9a00815ed6dc383630795cb4
diff --git a/sci-libs/gvar/gvar-13.0.2.ebuild b/sci-libs/gvar/gvar-13.0.2.ebuild
new file mode 100644
index 000000000..b9d9121e4
--- /dev/null
+++ b/sci-libs/gvar/gvar-13.0.2.ebuild
@@ -0,0 +1,22 @@
+EAPI=8
+
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Gaussian random variables."
+HOMEPAGE="https://github.com/gplepage/gvar"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/cython-0.17[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
diff --git a/sci-libs/gvar/metadata.xml b/sci-libs/gvar/metadata.xml
new file mode 100644
index 000000000..31346f0dd
--- /dev/null
+++ b/sci-libs/gvar/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package facilitates the creation and manipulation of arbitrarily complicated (correlated) multi-dimensional Gaussian random variables. The random variables are represented by a new data type (gvar.GVar) that can be used in arithmetic expressions and pure Python functions. Such expressions/functions create new Gaussian random variables while automatically tracking statistical correlations between the new and old variables. This data type is useful for simple error propagation, but also is heavily used by the Bayesian least-squares fitting module lsqfit.py to define priors and specify fit results, while accounting for correlations between all variables.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">gvar</remote-id>
+ <remote-id type="github">gplepage/gvar</remote-id>
+ </upstream>
+</pkgmetadata>