aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/handyg/handyg-0.1.5.ebuild')
-rw-r--r--sci-libs/handyg/handyg-0.1.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/handyg/handyg-0.1.5.ebuild b/sci-libs/handyg/handyg-0.1.5.ebuild
new file mode 100644
index 000000000..97a18c08e
--- /dev/null
+++ b/sci-libs/handyg/handyg-0.1.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Rapid numerical evaluation of generalised polylogarithms"
+HOMEPAGE="https://gitlab.com/mule-tools/handyg"
+SRC_URI="https://gitlab.com/mule-tools/${PN}/-/archive/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/fortran
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-so.patch"
+)
+
+src_configure() {
+ tc-export CC CXX FC AR
+ FFLAGS="${FFLAGS} -fPIC" LD="${FC}" ./configure --prefix="${EPREFIX}/usr" LDFLAGS="${LDFLAGS}"
+}
+
+src_compile() {
+ # single thread force needed since fortan mods depend on each other
+ export MAKEOPTS=-j1
+ emake all
+}
+
+src_install() {
+ dolib.a libhandyg.a
+ dolib.so libhandyg.so
+ doheader handyg.mod
+ dobin geval
+}