aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack-reference/lapack-reference-9999.ebuild')
-rw-r--r--sci-libs/lapack-reference/lapack-reference-9999.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/sci-libs/lapack-reference/lapack-reference-9999.ebuild b/sci-libs/lapack-reference/lapack-reference-9999.ebuild
index 75000ddd0..0ba3b3fd0 100644
--- a/sci-libs/lapack-reference/lapack-reference-9999.ebuild
+++ b/sci-libs/lapack-reference/lapack-reference-9999.ebuild
@@ -79,6 +79,7 @@ src_configure() {
local libname="${profname//-/_}"
local blas_profname=$(fortran-int64_get_blas_profname)
local xblas_profname=$(fortran-int64_get_xblas_profname)
+ local xblas_libname="${xblas_profname//-/_}"
local blas_requires="${blas_profname}"
use xblas && \
blas_requires+=" ${xblas_profname}"
@@ -94,6 +95,7 @@ src_configure() {
-DCMAKE_CXX_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CXXFLAGS}"
-DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(fortran-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
-DLAPACK_PKGCONFIG_FFLAGS="$(fortran-int64_get_fortran_int64_abi_fflags)"
+ -DXBLAS_LIBRARY:FILEPATH="${ROOT}usr/$(get_libdir)/lib${xblas_libname}.so"
)
if $(fortran-int64_is_static_build); then
mycmakeargs+=(