aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libStatGen/libStatGen-1.0.15.ebuild')
-rw-r--r--sci-libs/libStatGen/libStatGen-1.0.15.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/libStatGen/libStatGen-1.0.15.ebuild b/sci-libs/libStatGen/libStatGen-1.0.15.ebuild
new file mode 100644
index 000000000..fba3dde57
--- /dev/null
+++ b/sci-libs/libStatGen/libStatGen-1.0.15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="media-gfx/graphviz"
+
+inherit docs
+
+DESCRIPTION="Set of classes for creating statistical genetic programs"
+HOMEPAGE="https://github.com/statgen/libStatGen"
+SRC_URI="https://github.com/statgen/libStatGen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install(){
+ default
+ dolib.a libStatGen.a # package only makes a static library
+}