aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libmaus2/libmaus2-9999.ebuild')
-rw-r--r--sci-libs/libmaus2/libmaus2-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/libmaus2/libmaus2-9999.ebuild b/sci-libs/libmaus2/libmaus2-9999.ebuild
index c371d5432..d2cbd9439 100644
--- a/sci-libs/libmaus2/libmaus2-9999.ebuild
+++ b/sci-libs/libmaus2/libmaus2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,8 +15,6 @@ KEYWORDS=""
IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
- !sci-libs/libmaus
- >=sci-libs/io_lib-1.14.11
app-arch/snappy
sci-libs/fftw
sci-libs/hdf5
@@ -34,12 +32,14 @@ src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
+ # --with-io_lib
+ # will require >=sci-libs/io_lib-1.14.11 which is not yet available in ::gentoo
}
pkg_postinst(){
- einfo "The io_lib, snappy dependencies are not strictly needed"
+ einfo "The snappy dependency is not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}