aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libxc/libxc-9999.ebuild')
-rw-r--r--sci-libs/libxc/libxc-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sci-libs/libxc/libxc-9999.ebuild b/sci-libs/libxc/libxc-9999.ebuild
index 14fdb4026..761f43f3f 100644
--- a/sci-libs/libxc/libxc-9999.ebuild
+++ b/sci-libs/libxc/libxc-9999.ebuild
@@ -2,26 +2,20 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=3
-inherit eutils multilib toolchain-funcs flag-o-matic autotools subversion
+inherit autotools eutils flag-o-matic fortran-2 multilib subversion toolchain-funcs
-DESCRIPTION="The ETSF library of exchange-correlation functionals"
+DESCRIPTION="A library of exchange-correlation functionals"
HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
ESVN_REPO_URI="http://www.tddft.org/svn/octopus/trunk/${PN}/"
ESVN_BOOTSTRAP="eautoreconf -i"
LICENSE="LGPL-3"
SLOT="0"
-IUSE="fortran debug"
+IUSE="debug fortran"
KEYWORDS="~amd64 ~x86"
-pkg_setup() {
- if use fortran ; then
- tc-export FC
- fi
-}
-
src_configure() {
econf \
$(use_enable fortran) \