aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lwpr/lwpr-1.2.5.ebuild')
-rw-r--r--sci-libs/lwpr/lwpr-1.2.5.ebuild47
1 files changed, 22 insertions, 25 deletions
diff --git a/sci-libs/lwpr/lwpr-1.2.5.ebuild b/sci-libs/lwpr/lwpr-1.2.5.ebuild
index 9ae5de227..2f040a86e 100644
--- a/sci-libs/lwpr/lwpr-1.2.5.ebuild
+++ b/sci-libs/lwpr/lwpr-1.2.5.ebuild
@@ -1,47 +1,44 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit autotools-utils
+DOCS_BUILDER="doxygen"
+
+inherit docs
DESCRIPTION="The Locally Weighted Projection Regression Library"
-HOMEPAGE="http://www.ipab.inf.ed.ac.uk/slmc/software/lwpr/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="https://web.inf.ed.ac.uk/slmc"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples octave static-libs"
+IUSE="examples octave static-libs"
-RDEPEND="
- octave? ( >=sci-mathematics/octave-3 )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+RDEPEND="octave? ( >=sci-mathematics/octave-3 )"
+DEPEND="${RDEPEND}"
src_configure() {
- local myeconfargs=(
- --enable-threads=3
- $(use_with octave octave "$(octave-config -p PREFIX)")
- )
- autotools-utils_src_configure
+ econf \
+ --enable-threads=3 \
+ $(use_with octave octave)
}
src_compile() {
- autotools-utils_src_compile
- if use doc; then
- doxygen Doxyfile || die "doxygen failed"
- fi
+ default
+ docs_compile
}
src_install() {
- autotools-utils_src_install \
- mexflags="-DMATLAB -I../include -L./.libs -llwproctave"
- use doc && dodoc doc/lwpr_doc.pdf && dohtml html/*
+ default
+ if use doc; then
+ dodoc doc/lwpr_doc.pdf
+ dodoc html/*
+ fi
if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins example_c/cross.c example_cpp/cross.cc
+ docinto /usr/share/doc/${PF}/examples
+ dodoc example_c/cross.c example_cpp/cross.cc
fi
if use octave; then
insinto /usr/share/octave/packages/${P}