aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mpfun90/mpfun90-2023.02.26.ebuild')
-rw-r--r--sci-libs/mpfun90/mpfun90-2023.02.26.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/mpfun90/mpfun90-2023.02.26.ebuild b/sci-libs/mpfun90/mpfun90-2023.02.26.ebuild
new file mode 100644
index 000000000..4f885fa2c
--- /dev/null
+++ b/sci-libs/mpfun90/mpfun90-2023.02.26.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs fortran-2
+
+DESCRIPTION="High-Precision Software"
+HOMEPAGE="
+ https://www.davidhbailey.com/dhbsoftware/
+ https://github.com/APN-Pucky/mpfun90
+"
+MY_PV=$(ver_rs 1- '-')
+SRC_URI="https://github.com/APN-Pucky/mpfun90/archive/refs/tags/${MY_PV}.tar.gz"
+S="${WORKDIR}/mpfun90-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake -j1 dynamic
+}
+
+src_install() {
+ doheader *.mod
+ dolib.so libmpfun90.so
+ dolib.a libmpfun90.a
+}