aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mpfun90')
-rw-r--r--sci-libs/mpfun90/Manifest1
-rw-r--r--sci-libs/mpfun90/metadata.xml18
-rw-r--r--sci-libs/mpfun90/mpfun90-2023.02.26.ebuild29
3 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/mpfun90/Manifest b/sci-libs/mpfun90/Manifest
new file mode 100644
index 000000000..56d64f14c
--- /dev/null
+++ b/sci-libs/mpfun90/Manifest
@@ -0,0 +1 @@
+DIST 2023-02-26.tar.gz 66883 BLAKE2B 3b93099977b614e0d9a16df76f7f3c1eda9b76905664db3f0dc0ad0bd00b503105649aeb4c960d7293e7d536e3a902dbe8cb62f89be3bce655e9bae963097f35 SHA512 7280ecba6cb95f15cea91ea95f5cf21b69f76a490a3c92bef40cf8a1dfadd651cb93480bddddd684d0f18144db65cdb1590964df11d37a9f35eaeeb94f369d63
diff --git a/sci-libs/mpfun90/metadata.xml b/sci-libs/mpfun90/metadata.xml
new file mode 100644
index 000000000..e3eb0d9c1
--- /dev/null
+++ b/sci-libs/mpfun90/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package permits one to perform floating-point computations (real and complex) to arbitrarily high numeric precision
+ </longdescription>
+ <upstream>
+ <remote-id type="github">APN-Pucky/mpfun90</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/mpfun90/mpfun90-2023.02.26.ebuild b/sci-libs/mpfun90/mpfun90-2023.02.26.ebuild
new file mode 100644
index 000000000..4f885fa2c
--- /dev/null
+++ b/sci-libs/mpfun90/mpfun90-2023.02.26.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs fortran-2
+
+DESCRIPTION="High-Precision Software"
+HOMEPAGE="
+ https://www.davidhbailey.com/dhbsoftware/
+ https://github.com/APN-Pucky/mpfun90
+"
+MY_PV=$(ver_rs 1- '-')
+SRC_URI="https://github.com/APN-Pucky/mpfun90/archive/refs/tags/${MY_PV}.tar.gz"
+S="${WORKDIR}/mpfun90-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake -j1 dynamic
+}
+
+src_install() {
+ doheader *.mod
+ dolib.so libmpfun90.so
+ dolib.a libmpfun90.a
+}