aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/openblas/files/openblas-0.2.19-MAKE.patch')
-rw-r--r--sci-libs/openblas/files/openblas-0.2.19-MAKE.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/openblas/files/openblas-0.2.19-MAKE.patch b/sci-libs/openblas/files/openblas-0.2.19-MAKE.patch
new file mode 100644
index 000000000..c77dd0f93
--- /dev/null
+++ b/sci-libs/openblas/files/openblas-0.2.19-MAKE.patch
@@ -0,0 +1,29 @@
+diff --git a/Makefile b/Makefile
+index 2ae0047..2071e10 100644
+--- a/Makefile
++++ b/Makefile
+@@ -278,13 +278,13 @@ lapack-timing : large.tgz timing.tgz
+ ifndef NOFORTRAN
+ (cd $(NETLIB_LAPACK_DIR); $(TAR) zxf ../timing.tgz TIMING)
+ (cd $(NETLIB_LAPACK_DIR)/TIMING; $(TAR) zxf ../../large.tgz )
+- make -C $(NETLIB_LAPACK_DIR)/TIMING
++ $(MAKE) -C $(NETLIB_LAPACK_DIR)/TIMING
+ endif
+
+
+ lapack-test :
+ (cd $(NETLIB_LAPACK_DIR)/TESTING && rm -f x* *.out)
+- make -j 1 -C $(NETLIB_LAPACK_DIR)/TESTING xeigtstc xeigtstd xeigtsts xeigtstz xlintstc xlintstd xlintstds xlintstrfd xlintstrfz xlintsts xlintstz xlintstzc xlintstrfs xlintstrfc
++ $(MAKE) -j 1 -C $(NETLIB_LAPACK_DIR)/TESTING xeigtstc xeigtstd xeigtsts xeigtstz xlintstc xlintstd xlintstds xlintstrfd xlintstrfz xlintsts xlintstz xlintstzc xlintstrfs xlintstrfc
+ ifneq ($(CROSS), 1)
+ ( cd $(NETLIB_LAPACK_DIR)/INSTALL; ./testlsame; ./testslamch; ./testdlamch; \
+ ./testsecond; ./testdsecnd; ./testieee; ./testversion )
+@@ -299,7 +299,7 @@ lapack-runtest:
+
+ blas-test:
+ (cd $(NETLIB_LAPACK_DIR)/BLAS && rm -f x* *.out)
+- make -j 1 -C $(NETLIB_LAPACK_DIR) blas_testing
++ $(MAKE) -j 1 -C $(NETLIB_LAPACK_DIR) blas_testing
+ (cd $(NETLIB_LAPACK_DIR)/BLAS && cat *.out)
+
+