aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pfft/pfft-9999.ebuild')
-rw-r--r--sci-libs/pfft/pfft-9999.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/sci-libs/pfft/pfft-9999.ebuild b/sci-libs/pfft/pfft-9999.ebuild
index 1ad55311a..af9a0f88e 100644
--- a/sci-libs/pfft/pfft-9999.ebuild
+++ b/sci-libs/pfft/pfft-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools-utils fortran-2 multibuild
+inherit fortran-2 multibuild
DESCRIPTION="Parallel 3d FFT"
HOMEPAGE="https://www-user.tu-chemnitz.de/~potts/workgroup/pippig/software.php.en"
@@ -11,11 +11,10 @@ HOMEPAGE="https://www-user.tu-chemnitz.de/~potts/workgroup/pippig/software.php.e
if [[ $PV = *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mpip/pfft.git"
- KEYWORDS=""
AUTOTOOLS_AUTORECONF=1
else
SRC_URI="https://www-user.tu-chemnitz.de/~potts/workgroup/pippig/software/${P//_/-}.tar.gz"
- KEYWORDS="~x86 ~amd64"
+ KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${P//_/-}"
fi
@@ -26,28 +25,23 @@ IUSE="static-libs"
RDEPEND="
sci-libs/fftw:3.0[mpi,fortran]
virtual/mpi
- "
+"
-DEPEND="
- ${RDEPEND}
- "
+DEPEND="${RDEPEND}"
src_configure() {
MULTIBUILD_VARIANTS=( single double long-double )
my_src_configure() {
- local myeconfargs=(
- $([[ ${MULTIBUILD_VARIANT} != double ]] && echo "--enable-${MULTIBUILD_VARIANT}")
- )
- autotools-utils_src_configure
+ econf $([[ ${MULTIBUILD_VARIANT} != double ]] && echo "--enable-${MULTIBUILD_VARIANT}")
}
- multibuild_parallel_foreach_variant my_src_configure
+ multibuild_foreach_variant my_src_configure
}
src_compile() {
- multibuild_foreach_variant autotools-utils_src_compile
+ multibuild_foreach_variant emake
}
src_install() {
- multibuild_parallel_foreach_variant autotools-utils_src_install
+ multibuild_foreach_variant emake install DESTDIR="${D}"
}