aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pybids/pybids-0.11.1.ebuild')
-rw-r--r--sci-libs/pybids/pybids-0.11.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/sci-libs/pybids/pybids-0.11.1.ebuild b/sci-libs/pybids/pybids-0.11.1.ebuild
deleted file mode 100644
index 062cad939..000000000
--- a/sci-libs/pybids/pybids-0.11.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python package to access BIDS datasets"
-HOMEPAGE="https://github.com/INCF/pybids"
-SRC_URI="https://github.com/INCF/pybids/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND=""
-RDEPEND="
- dev-python/num2words[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/patsy[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- sci-libs/bids-validator[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- "
-
-#RESTRICT="test"
-# Fails because fixtures are called directly
-# https://github.com/bids-standard/pybids/issues/289#issuecomment-476853673
-
-python_test() {
- #rm bids/tests/test_config.py || die
- distutils_install_for_testing
- pytest -vv || die
-}