aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rdkit/files/rdkit-2021.09.4-find-rapidjson.patch')
-rw-r--r--sci-libs/rdkit/files/rdkit-2021.09.4-find-rapidjson.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/rdkit/files/rdkit-2021.09.4-find-rapidjson.patch b/sci-libs/rdkit/files/rdkit-2021.09.4-find-rapidjson.patch
new file mode 100644
index 000000000..94a209e0f
--- /dev/null
+++ b/sci-libs/rdkit/files/rdkit-2021.09.4-find-rapidjson.patch
@@ -0,0 +1,22 @@
+diff --git a/Code/GraphMol/MolInterchange/CMakeLists.txt b/Code/GraphMol/MolInterchange/CMakeLists.txt
+index 8027444..6a8c715 100644
+--- a/Code/GraphMol/MolInterchange/CMakeLists.txt
++++ b/Code/GraphMol/MolInterchange/CMakeLists.txt
+@@ -1,16 +1,5 @@
+
+-if(NOT EXISTS "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0")
+- downloadAndCheckMD5("https://github.com/Tencent/rapidjson/archive/v1.1.0.tar.gz"
+- "${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz"
+- "badd12c511e081fec6c89c43a7027bce")
+- execute_process(COMMAND ${CMAKE_COMMAND} -E tar zxf
+- ${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0.tar.gz
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/External)
+-else()
+- message("-- Found RapidJSON source in ${CMAKE_SOURCE_DIR}/External")
+-endif()
+-
+-include_directories(${CMAKE_SOURCE_DIR}/External/rapidjson-1.1.0/include)
++include_directories(/usr/include/rapidjson)
+
+
+ rdkit_library(MolInterchange