aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rdkit/rdkit-9999.ebuild')
-rw-r--r--sci-libs/rdkit/rdkit-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/rdkit/rdkit-9999.ebuild b/sci-libs/rdkit/rdkit-9999.ebuild
new file mode 100644
index 000000000..dfa196f5b
--- /dev/null
+++ b/sci-libs/rdkit/rdkit-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit cmake-utils python-r1 git-r3
+
+DESCRIPTION="Cheminformatics and machine-learning software written in C++ and Python"
+HOMEPAGE="http://www.rdkit.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/rdkit/rdkit.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+python -static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/boost
+ python? (
+ dev-libs/boost[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ >=dev-db/sqlite-3"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX:PATH="${EPREFIX}"/usr
+ -DRDK_INSTALL_INTREE=0
+ -DRDK_BUILD_CPP_TESTS=OFF
+ )
+
+ if ! use static-libs; then
+ mycmakeargs+=( -DRDK_INSTALL_STATIC_LIBS=OFF )
+ fi
+
+ if ! use python; then
+ mycmakeargs+=( RDK_BUILD_PYTHON_WRAPPERS= )
+ fi
+
+ cmake-utils_src_configure
+}