aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rocBLAS/files')
-rw-r--r--sci-libs/rocBLAS/files/Tensile-4.0.0-locate-commands.patch32
-rw-r--r--sci-libs/rocBLAS/files/rocBLAS-4.0.0-use-system-tensile.patch30
2 files changed, 0 insertions, 62 deletions
diff --git a/sci-libs/rocBLAS/files/Tensile-4.0.0-locate-commands.patch b/sci-libs/rocBLAS/files/Tensile-4.0.0-locate-commands.patch
deleted file mode 100644
index 461a736a2..000000000
--- a/sci-libs/rocBLAS/files/Tensile-4.0.0-locate-commands.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: Tensile-rocm-4.0.0/Tensile/Common.py
-===================================================================
---- Tensile-rocm-4.0.0.orig/Tensile/Common.py
-+++ Tensile-rocm-4.0.0/Tensile/Common.py
-@@ -1521,14 +1521,14 @@ def assignGlobalParameters( config ):
- print2(" %24s: %8s (unspecified)" % (key, defaultValue))
-
- # ROCm Agent Enumerator Path
-- globalParameters["ROCmAgentEnumeratorPath"] = locateExe("/opt/rocm/bin", "rocm_agent_enumerator")
-+ globalParameters["ROCmAgentEnumeratorPath"] = locateExe("", "rocm_agent_enumerator")
- if "CxxCompiler" in config:
- globalParameters["CxxCompiler"] = config["CxxCompiler"]
-
- if "TENSILE_ROCM_ASSEMBLER_PATH" in os.environ:
- globalParameters["AssemblerPath"] = os.environ.get("TENSILE_ROCM_ASSEMBLER_PATH")
- elif globalParameters["AssemblerPath"] is None and globalParameters["CxxCompiler"] == "hipcc":
-- globalParameters["AssemblerPath"] = locateExe("/opt/rocm/llvm/bin", "clang++")
-+ globalParameters["AssemblerPath"] = locateExe("", "clang++")
- elif globalParameters["AssemblerPath"] is None and globalParameters["CxxCompiler"] == "hcc":
- globalParameters["AssemblerPath"] = locateExe("/opt/rocm/bin", "hcc")
-
-@@ -1536,8 +1536,8 @@ def assignGlobalParameters( config ):
- if globalParameters["CxxCompiler"] == "hcc":
- globalParameters["ExtractKernelPath"] = locateExe("/opt/rocm/bin", "extractkernel")
- else:
-- globalParameters["ExtractKernelPath"] = locateExe("/opt/rocm/hip/bin", "extractkernel")
-- globalParameters["ClangOffloadBundlerPath"] = locateExe("/opt/rocm/llvm/bin", "clang-offload-bundler")
-+ globalParameters["ExtractKernelPath"] = locateExe("", "extractkernel")
-+ globalParameters["ClangOffloadBundlerPath"] = locateExe("", "clang-offload-bundler")
-
- if "ROCmAgentEnumeratorPath" in config:
- globalParameters["ROCmAgentEnumeratorPath"] = config["ROCmAgentEnumeratorPath"]
diff --git a/sci-libs/rocBLAS/files/rocBLAS-4.0.0-use-system-tensile.patch b/sci-libs/rocBLAS/files/rocBLAS-4.0.0-use-system-tensile.patch
deleted file mode 100644
index 3b8e44a99..000000000
--- a/sci-libs/rocBLAS/files/rocBLAS-4.0.0-use-system-tensile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --color -uprN rocBLAS-rocm-4.0.0/CMakeLists.txt new/CMakeLists.txt
---- rocBLAS-rocm-4.0.0/CMakeLists.txt 2020-11-11 00:56:04.000000000 +0800
-+++ new/CMakeLists.txt 2021-01-20 15:23:09.570222990 +0800
-@@ -208,25 +208,7 @@ if( BUILD_WITH_TENSILE )
- option(TENSILE_USE_MSGPACK "Use msgpack for parsing config files." ON)
- endif()
-
-- include(virtualenv)
-- if (Tensile_TEST_LOCAL_PATH)
-- virtualenv_install(${Tensile_TEST_LOCAL_PATH})
-- message (STATUS "using local Tensile from ${Tensile_TEST_LOCAL_PATH}, copied to ${Tensile_ROOT}")
-- else()
-- # Use the virtual-env setup and download package from specified repot:
-- set( tensile_fork "ROCmSoftwarePlatform" CACHE STRING "Tensile fork to use" )
-- file (STRINGS "tensile_tag.txt" read_tensile_tag)
-- set( tensile_tag ${read_tensile_tag} CACHE STRING "Tensile tag to download" )
-- virtualenv_install("git+https://github.com/${tensile_fork}/Tensile.git@${tensile_tag}")
-- message (STATUS "using GIT Tensile fork=${tensile_fork} from branch=${tensile_tag}")
-- endif()
-- message(STATUS "Adding ${VIRTUALENV_HOME_DIR} to CMAKE_PREFIX_PATH")
-- list(APPEND CMAKE_PREFIX_PATH ${VIRTUALENV_HOME_DIR})
-- if (TENSILE_VERSION)
-- find_package(Tensile ${TENSILE_VERSION} EXACT REQUIRED HIP LLVM OpenMP PATHS "${INSTALLED_TENSILE_PATH}")
-- else()
-- find_package(Tensile 4.24.0 EXACT REQUIRED HIP LLVM OpenMP PATHS "${INSTALLED_TENSILE_PATH}")
-- endif()
-+ find_package(Tensile 4.24.0 EXACT REQUIRED HIP LLVM OpenMP)
- endif()
-
- # Find HCC/HIP dependencies