aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/spams-python')
-rw-r--r--sci-libs/spams-python/Manifest1
-rw-r--r--sci-libs/spams-python/metadata.xml24
-rw-r--r--sci-libs/spams-python/spams-python-2.6.2.ebuild60
3 files changed, 0 insertions, 85 deletions
diff --git a/sci-libs/spams-python/Manifest b/sci-libs/spams-python/Manifest
deleted file mode 100644
index d58c9e869..000000000
--- a/sci-libs/spams-python/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST spams-python-2.6.2.tar.gz 315332 BLAKE2B 1aa972a65c2f69de859391b98a28972ebbd30f166ea3d44083933f746e119105d45d6ee5adff99064dc396f5522c31e5dd4055210c82e93c1217a06bf4bce2f2 SHA512 dec2ce2abe5abeb78bf470952c5f854501bf9ea21019dda1de66683f813153e78cc9b87b5376e91ac74beedb4d13854cc053e54e97bfded4177728c540812a9f
diff --git a/sci-libs/spams-python/metadata.xml b/sci-libs/spams-python/metadata.xml
deleted file mode 100644
index 4cb1814dc..000000000
--- a/sci-libs/spams-python/metadata.xml
+++ /dev/null
@@ -1,24 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>gentoo@chymera.eu</email>
- <name>Horea Christian</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- SPAMS (SPArse Modeling Software) is an optimization toolbox for solving
- various sparse estimation problems, such as: Dictionary learning and
- matrix factorization (NMF, sparse PCA, ...); solving sparse decomposition
- problems with LARS, coordinate descent, OMP, SOMP, proximal methods; and
- Solving structured sparse decomposition problems (l1/l2, l1/linf, sparse
- group lasso, tree-structured regularization, structured sparsity with
- overlapping groups,...).
- </longdescription>
- <upstream>
- <remote-id type="github">samuelstjean/spams-python</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/spams-python/spams-python-2.6.2.ebuild b/sci-libs/spams-python/spams-python-2.6.2.ebuild
deleted file mode 100644
index 99b1e6370..000000000
--- a/sci-libs/spams-python/spams-python-2.6.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Optimization toolbox for solving various sparse estimation problems"
-HOMEPAGE="http://spams-devel.gforge.inria.fr/index.html"
-SRC_URI="https://github.com/samuelstjean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- sci-libs/openblas
- virtual/lapack
- "
-RDEPEND="${DEPEND}
- dev-python/scipy[${PYTHON_USEDEP}]
- "
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^,||'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
-}
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
-}
-
-python_prepare_all() {
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- MY_LAPACK=$(pc_libs lapack)
- MY_BLAS=$(pc_libs blas)
- MY_LIBDIRS="$(pc_libdir blas lapack)'${libdir}'"
- sed -i -e "s/'blas', 'lapack'/'${MY_BLAS}', '${MY_LAPACK}'/g" setup.py || die
- sed -i -e "s|libdirs = \[\]|libdirs = [${MY_LIBDIRS}]|g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ${EPYTHON} test_spams.py
-}