aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/starparse/starparse-9999_pre10.ebuild')
-rw-r--r--sci-libs/starparse/starparse-9999_pre10.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/sci-libs/starparse/starparse-9999_pre10.ebuild b/sci-libs/starparse/starparse-9999_pre10.ebuild
index 6f5777c34..874309cb5 100644
--- a/sci-libs/starparse/starparse-9999_pre10.ebuild
+++ b/sci-libs/starparse/starparse-9999_pre10.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EBZR_REPO_URI="http://oregonstate.edu/~benisong/software/projects/starparse/releases/1.0"
-EBZR_BOOTSTRAP="eautoreconf"
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="true"
-inherit autotools bzr
+inherit autotools-utils bzr
DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
HOMEPAGE="http://burrow-owl.sourceforge.net/"
#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+EBZR_REPO_URI="http://oregonstate.edu/~benisong/software/projects/starparse/releases/1.0"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="guile"
+IUSE="guile static-libs"
RDEPEND="guile? ( dev-scheme/guile )"
DEPEND="${RDEPEND}"
-src_compile() {
- econf $(use_enable guile) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+src_configure() {
+ local myeconfargs=( $(use_enable guile) )
+ autotools-utils_src_configure
}