aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/tensorflow/tensorflow-1.5.0.ebuild')
-rw-r--r--sci-libs/tensorflow/tensorflow-1.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
new file mode 100644
index 000000000..a62394c86
--- /dev/null
+++ b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Library for numerical computation using data flow graphs"
+HOMEPAGE="https://github.com/tensorflow/tensorflow"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="cuda mpi"
+
+DEPEND="dev-util/bazel
+ dev-python/wheel
+ dev-python/numpy
+ dev-libs/protobuf-c
+ cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# TODO: seems it also support some MPI implementation