aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/votca-tools/votca-tools-9999.ebuild')
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild30
1 files changed, 23 insertions, 7 deletions
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index e1dbf68bd..8ad9a6c96 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -8,19 +8,20 @@ inherit autotools mercurial
DESCRIPTION="Votca tools library"
HOMEPAGE="http://www.votca.org"
-SRC_URI=""
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE=""
+IUSE="-boost doc"
-DEPEND="sci-libs/fftw:3.0
- dev-libs/libxml2
+RDEPEND="sci-libs/fftw:3.0
+ dev-libs/expat
sci-libs/gsl
- >=dev-libs/boost-1.33.1"
+ boost? ( >=dev-libs/boost-1.33.1 )
+ doc? ( >=app-text/txt2tags-2.5 )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
EHG_REPO_URI="https://tools.votca.googlecode.com/hg/"
@@ -31,7 +32,13 @@ src_prepare() {
}
src_configure() {
- econf || die "econf failed"
+ local myconf="--disable-la-files"
+
+ use boost \
+ && myconf="${myconf} $(use_with boost) --disable-votca-boost" \
+ || myconf="${myconf} $(use_with boost) --enable-votca-boost"
+
+ econf ${myconf} || die "econf failed"
}
src_compile() {
@@ -41,4 +48,13 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
dodoc NOTICE
+ if use doc; then
+ emake CHANGELOG || die "emake CHANGELOG failed"
+ dodoc CHANGELOG
+ fi
+
+ sed -n -e '/^VOTCA\(BIN\|LDLIB\)/p' \
+ "${D}"/usr/bin/VOTCARC.bash >> "${T}/80${PN}"
+ doenvd "${T}/80${PN}"
+ rm -f "${D}"/usr/bin/VOTCARC*
}