aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/matio/ChangeLog6
-rw-r--r--sci-libs/matio/matio-1.3.4.ebuild21
2 files changed, 16 insertions, 11 deletions
diff --git a/sci-libs/matio/ChangeLog b/sci-libs/matio/ChangeLog
index 620f108b5..bed9be26c 100644
--- a/sci-libs/matio/ChangeLog
+++ b/sci-libs/matio/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-libs/matio
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 11 Jan 2015; Marius Brehler <marbre@linux.sungazer.de> matio-1.3.4.ebuild:
+ Move to EAPI=5, cleanup the ebuild
+
+
21 Jun 2011; Justin Lecher <jlec@gentoo.org> matio-1.3.4.ebuild:
Added fortran-2.eclass support
diff --git a/sci-libs/matio/matio-1.3.4.ebuild b/sci-libs/matio/matio-1.3.4.ebuild
index 5f948f6bd..8471e8c21 100644
--- a/sci-libs/matio/matio-1.3.4.ebuild
+++ b/sci-libs/matio/matio-1.3.4.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
-inherit autotools eutils fortran-2
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils fortran-2
DESCRIPTION="Library for reading and writing matlab files"
HOMEPAGE="http://sourceforge.net/projects/matio/"
@@ -16,23 +18,22 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
#DEPEND="doc? ( app-doc/doxygen virtual/latex-base )"
RDEPEND=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-autotools.patch
- eautoreconf
-}
+PATCHES=( "${FILESDIR}/${P}"-autotools.patch )
src_configure() {
- econf \
+ local myeconfargs=(
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--enable-shared \
--disable-test \
$(use_enable fortran) \
- $(use_enable doc docs) \
+ #$(use_enable doc docs) \
$(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ autotools-utils_src_install
dodoc README ChangeLog
#if use doc; then
# insinto /usr/share/doc/${PF}