aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vxl/Manifest1
-rw-r--r--sci-libs/vxl/vxl-2.0.2.ebuild23
-rw-r--r--sci-libs/vxl/vxl-9999.ebuild16
3 files changed, 24 insertions, 16 deletions
diff --git a/sci-libs/vxl/Manifest b/sci-libs/vxl/Manifest
new file mode 100644
index 000000000..59438eca7
--- /dev/null
+++ b/sci-libs/vxl/Manifest
@@ -0,0 +1 @@
+DIST vxl-2.0.2.tar.gz 44159163 BLAKE2B 338535c08a7f2728f4c8bce1e84a4c60a23907ba2907dcf137ebdff271e9b6cf9bf1543732b9a95eda967127b571512f5eced0262e99c04febd60e79cf78272b SHA512 113a94cd4e904d39d6ee9a854523de09f607570b97acef8e83ce95f71439549abe9f15b0bc367a0c193b2da2b68acea6b4263660bcf979fc0f87c10193253fb3
diff --git a/sci-libs/vxl/vxl-2.0.2.ebuild b/sci-libs/vxl/vxl-2.0.2.ebuild
new file mode 100644
index 000000000..0680cceb3
--- /dev/null
+++ b/sci-libs/vxl/vxl-2.0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake multilib
+
+DESCRIPTION="C++ computer vision research libraries"
+HOMEPAGE="https://vxl.github.io/"
+SRC_URI="https://github.com/vxl/vxl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sci-libs/libgeotiff"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ # install lib files to correct dir
+ mv "${ED}/usr/lib" "${ED}/usr/$(get_libdir)"
+}
diff --git a/sci-libs/vxl/vxl-9999.ebuild b/sci-libs/vxl/vxl-9999.ebuild
deleted file mode 100644
index ab92e482e..000000000
--- a/sci-libs/vxl/vxl-9999.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils git-r3
-
-DESCRIPTION="C++ computer vision research libraries"
-HOMEPAGE="http://vxl.sourceforge.net"
-SRC_URI=""
-EGIT_REPO_URI="http://git.code.sf.net/p/vxl/git"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-KEYWORDS=""