aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/acl2')
-rw-r--r--sci-mathematics/acl2/Manifest2
-rw-r--r--sci-mathematics/acl2/acl2-8.3-r1.ebuild86
-rw-r--r--sci-mathematics/acl2/acl2-8.3-r2.ebuild89
-rw-r--r--sci-mathematics/acl2/acl2-8.4-r1.ebuild89
-rw-r--r--sci-mathematics/acl2/acl2-8.4.ebuild86
-rw-r--r--sci-mathematics/acl2/files/acl2-use_make_variable.patch13
-rw-r--r--sci-mathematics/acl2/metadata.xml25
7 files changed, 0 insertions, 390 deletions
diff --git a/sci-mathematics/acl2/Manifest b/sci-mathematics/acl2/Manifest
deleted file mode 100644
index b824d2c10..000000000
--- a/sci-mathematics/acl2/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST acl2-8.3.tar.gz 116808616 BLAKE2B 77bba8c91231c2ae6ebae34ceeec9939101862156bfda4be2a0e3389f51cfdc183004d9cb3b27511a7494a9ead8ced5016f648a1712ab468c781dd8f8feca822 SHA512 92b59d1b31ce8d980bf043d02d4ee6ae36c69b3c2cc7be106e4d8f46e660a813e42f6e41a0903159ce65e9332dccb770cbd69472602889724f8ba724bfa301e2
-DIST acl2-8.4.tar.gz 202242463 BLAKE2B 887273910c7913d08455e5053a4c4d065743e0ba247f94f994a3400f27c97f8fce07debb145dbf26287c8b72e9335d995fcbc49f7085e17384b38035d260c8b8 SHA512 5a38271ffa9f9aad79d2aaf575144a58cf1b926b9ba3f9fb34af927862c95f6f683e870c9b453b2527abe8bdcd5603c6b5ad4c50b70c407606db78e0a79545bb
diff --git a/sci-mathematics/acl2/acl2-8.3-r1.ebuild b/sci-mathematics/acl2/acl2-8.3-r1.ebuild
deleted file mode 100644
index d0bb4eade..000000000
--- a/sci-mathematics/acl2/acl2-8.3-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common
-
-DESCRIPTION="Industrial strength theorem prover"
-HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/"
-SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="books doc emacs"
-
-BDEPEND="
- dev-lisp/sbcl
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-DEPEND="
- dev-lisp/sbcl:=
- books? ( dev-lang/perl )
- doc? ( dev-lang/perl )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-use_make_variable.patch )
-
-src_prepare() {
- find . -type f -name "*.bak" -delete
- find . -type f -name "*.orig" -delete
- # Remove sparc binary inadvertently included in upstream
- rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
- default
-}
-
-src_compile() {
- emake LISP="sbcl --noinform --noprint \
- --no-sysinit --no-userinit --disable-debugger"
-
- if use books; then
- emake "ACL2=${S}/saved_acl2" basic
- fi
-
- if use doc; then
- emake "ACL2=${S}/saved_acl2" DOC
- fi
-
- if use emacs; then
- elisp-compile emacs/*.el
- fi
-}
-
-src_install() {
- local SAVED_NAME=saved_acl2
- sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
- dobin ${SAVED_NAME}
-
- insinto /usr/share/acl2
- doins ${SAVED_NAME}.core
- if use books; then
- sed -e "/5/a export ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
- -i ${SAVED_NAME} || die
- doins -r books
- fi
-
- DOCS=( books/README.md )
- if use doc; then
- HTML_DOCS=( doc/HTML/. )
- fi
- einstalldocs
-
- if use emacs; then
- elisp-install ${PN} emacs/*{.el,elc}
- doins TAGS
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/acl2/acl2-8.3-r2.ebuild b/sci-mathematics/acl2/acl2-8.3-r2.ebuild
deleted file mode 100644
index 03cd890b4..000000000
--- a/sci-mathematics/acl2/acl2-8.3-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common
-
-DESCRIPTION="Industrial strength theorem prover"
-HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/"
-SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="books doc emacs"
-
-BDEPEND="
- dev-lisp/sbcl
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-DEPEND="
- dev-lisp/sbcl:=
- books? ( dev-lang/perl )
- doc? ( dev-lang/perl )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-use_make_variable.patch )
-
-src_prepare() {
- find . -type f -name "*.bak" -delete
- find . -type f -name "*.orig" -delete
- # Remove sparc binary inadvertently included in upstream
- rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
- default
-}
-
-src_compile() {
- emake LISP="sbcl --noinform --noprint \
- --no-sysinit --no-userinit --disable-debugger"
-
- if use books; then
- emake "ACL2=${S}/saved_acl2" basic
- fi
-
- if use doc; then
- emake "ACL2=${S}/saved_acl2" DOC
- fi
-
- if use emacs; then
- elisp-compile emacs/*.el
- fi
-}
-
-src_install() {
- local SAVED_NAME=saved_acl2
- sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
- if use books; then
- sed -e "5iexport ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
- -i ${SAVED_NAME} || die
- fi
- dobin ${SAVED_NAME}
-
- insinto /usr/share/acl2
- doins ${SAVED_NAME}.core
-
- if use books; then
- doins -r books
- fi
-
- DOCS=( books/README.md )
- if use doc; then
- HTML_DOCS=( doc/HTML/. )
- fi
- einstalldocs
-
- if use emacs; then
- elisp-install ${PN} emacs/*{.el,elc}
- doins TAGS
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/acl2/acl2-8.4-r1.ebuild b/sci-mathematics/acl2/acl2-8.4-r1.ebuild
deleted file mode 100644
index cb1098877..000000000
--- a/sci-mathematics/acl2/acl2-8.4-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common
-
-DESCRIPTION="Industrial strength theorem prover"
-HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/"
-SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="books doc emacs"
-
-BDEPEND="
- >=dev-lisp/sbcl-1.5.2
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-DEPEND="
- dev-lisp/sbcl:=
- books? ( dev-lang/perl )
- doc? ( dev-lang/perl )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-use_make_variable.patch )
-
-src_prepare() {
- find . -type f -name "*.bak" -delete
- find . -type f -name "*.orig" -delete
- # Remove sparc binary inadvertently included in upstream
- rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
- default
-}
-
-src_compile() {
- emake LISP="sbcl --noinform --noprint \
- --no-sysinit --no-userinit --disable-debugger"
-
- if use books; then
- emake "ACL2=${S}/saved_acl2" basic
- fi
-
- if use doc; then
- emake "ACL2=${S}/saved_acl2" DOC
- fi
-
- if use emacs; then
- elisp-compile emacs/*.el
- fi
-}
-
-src_install() {
- local SAVED_NAME=saved_acl2
- sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
- if use books; then
- sed -e "5iexport ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
- -i ${SAVED_NAME} || die
- fi
- dobin ${SAVED_NAME}
-
- insinto /usr/share/acl2
- doins ${SAVED_NAME}.core
-
- if use books; then
- doins -r books
- fi
-
- DOCS=( books/README.md )
- if use doc; then
- HTML_DOCS=( doc/HTML/. )
- fi
- einstalldocs
-
- if use emacs; then
- elisp-install ${PN} emacs/*{.el,elc}
- doins TAGS
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/acl2/acl2-8.4.ebuild b/sci-mathematics/acl2/acl2-8.4.ebuild
deleted file mode 100644
index dfc3967ed..000000000
--- a/sci-mathematics/acl2/acl2-8.4.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp-common
-
-DESCRIPTION="Industrial strength theorem prover"
-HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/"
-SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="books doc emacs"
-
-BDEPEND="
- >=dev-lisp/sbcl-1.5.2
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-DEPEND="
- dev-lisp/sbcl:=
- books? ( dev-lang/perl )
- doc? ( dev-lang/perl )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-use_make_variable.patch )
-
-src_prepare() {
- find . -type f -name "*.bak" -delete
- find . -type f -name "*.orig" -delete
- # Remove sparc binary inadvertently included in upstream
- rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
- default
-}
-
-src_compile() {
- emake LISP="sbcl --noinform --noprint \
- --no-sysinit --no-userinit --disable-debugger"
-
- if use books; then
- emake "ACL2=${S}/saved_acl2" basic
- fi
-
- if use doc; then
- emake "ACL2=${S}/saved_acl2" DOC
- fi
-
- if use emacs; then
- elisp-compile emacs/*.el
- fi
-}
-
-src_install() {
- local SAVED_NAME=saved_acl2
- sed -e "s:${S}:/usr/share/acl2:g" -i ${SAVED_NAME} || die
- dobin ${SAVED_NAME}
-
- insinto /usr/share/acl2
- doins ${SAVED_NAME}.core
- if use books; then
- sed -e "/5/a export ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
- -i ${SAVED_NAME} || die
- doins -r books
- fi
-
- DOCS=( books/README.md )
- if use doc; then
- HTML_DOCS=( doc/HTML/. )
- fi
- einstalldocs
-
- if use emacs; then
- elisp-install ${PN} emacs/*{.el,elc}
- doins TAGS
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/acl2/files/acl2-use_make_variable.patch b/sci-mathematics/acl2/files/acl2-use_make_variable.patch
deleted file mode 100644
index 32e0f05da..000000000
--- a/sci-mathematics/acl2/files/acl2-use_make_variable.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-use make variable to avoid QA issue: "make[1]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule"
-
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -576,7 +576,7 @@ doc/home-page.html: doc/home-page.lisp
- # xdoc::save that populates doc/manual/ (not under books/).
- acl2-manual: check-books
- rm -rf doc/manual books/system/doc/acl2-manual.cert
-- cd books ; make USE_QUICKLISP=1 system/doc/acl2-manual.cert
-+ cd books ; $(MAKE) USE_QUICKLISP=1 system/doc/acl2-manual.cert
- rm -rf doc/manual/download/*
-
- # WARNING: The dependency list just below isn't complete, since it
diff --git a/sci-mathematics/acl2/metadata.xml b/sci-mathematics/acl2/metadata.xml
deleted file mode 100644
index b3d826757..000000000
--- a/sci-mathematics/acl2/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>dongxuli2011@gmail.com</email>
- <name>Dongxu Li</name>
- <description>Industrial strength theorem prover</description>
- </maintainer>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription>
- ACL2 is both a programming language in which you can model computer systems and
- a tool to help you prove properties of those models. ACL2 is part of the
- Boyer-Moore family of provers, for which its authors have received the 2005 ACM
- Software System Award.
- </longdescription>
- <use>
- <flag name="books">build community books, the canonical collection of open-source libraries</flag>
- </use>
- <upstream>
- <remote-id type="github">acl2/acl2</remote-id>
- </upstream>
-</pkgmetadata>