aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/apron/apron-0.9.10.ebuild')
-rw-r--r--sci-mathematics/apron/apron-0.9.10.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/sci-mathematics/apron/apron-0.9.10.ebuild b/sci-mathematics/apron/apron-0.9.10.ebuild
index ad2356bec..4d82cca16 100644
--- a/sci-mathematics/apron/apron-0.9.10.ebuild
+++ b/sci-mathematics/apron/apron-0.9.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,25 +6,25 @@ EAPI="2"
inherit eutils toolchain-funcs
-DESCRIPTION="APRON is a library dedicated to the static analysis of the numerical variables of a program by Abstract Interpretation"
+DESCRIPTION="Library for static analysis of the numerical variables of a program by Abstract Interpretation"
HOMEPAGE="http://apron.cri.ensmp.fr/library/"
SRC_URI="http://apron.cri.ensmp.fr/library/${P}.tgz"
LICENSE="LGPL-2 GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="cxx doc ocaml ppl"
-DEPEND="ocaml? ( >=dev-lang/ocaml-3.09
- dev-ml/camlidl
+RDEPEND="ocaml? ( >=dev-lang/ocaml-3.09
+ dev-ml/camlidl
dev-ml/mlgmpidl )
dev-libs/gmp
dev-libs/mpfr
- ppl? ( dev-libs/ppl )
+ ppl? ( dev-libs/ppl )"
+DEPEND="${RDEPEND}
doc? ( app-text/texlive
- app-text/ghostscript-gpl
+ app-text/ghostscript-gpl
cxx? ( app-doc/doxygen ) )"
-RDEPEND="${DEPEND}"
src_prepare() {
mv Makefile.config.model Makefile.config
@@ -35,7 +35,7 @@ src_prepare() {
-e "s/-O3 -DNDEBUG/-DNDEBUG/g" \
-e "s/APRON_PREFIX =.*/APRON_PREFIX = \${DESTDIR}\/usr/g" \
-e "s/MLGMPIDL_PREFIX =.*/MLGMPIDL_PREFIX = \${DESTDIR}\/usr/g"
-
+
#fix doc building process
sed -i Makefile -e "s/; make html/; make/g"
sed -i apronxx/doc/Doxyfile \
@@ -72,7 +72,7 @@ src_compile() {
src_install(){
emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS Changes COPYING README
+ dodoc AUTHORS Changes README
if use doc; then
dodoc apron/apron.pdf
@@ -85,4 +85,3 @@ src_install(){
fi
fi
}
-