aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/dolfin')
-rw-r--r--sci-mathematics/dolfin/Manifest3
-rw-r--r--sci-mathematics/dolfin/dolfin-0.9.9.ebuild56
-rw-r--r--sci-mathematics/dolfin/dolfin-2016.2.0-r2.ebuild80
-rw-r--r--sci-mathematics/dolfin/dolfin-2017.1.0.ebuild80
-rw-r--r--sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch25
-rw-r--r--sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch21
-rw-r--r--sci-mathematics/dolfin/metadata.xml26
7 files changed, 0 insertions, 291 deletions
diff --git a/sci-mathematics/dolfin/Manifest b/sci-mathematics/dolfin/Manifest
deleted file mode 100644
index 67b7f0be8..000000000
--- a/sci-mathematics/dolfin/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST dolfin-0.9.9.tar.gz 10229504 BLAKE2B dc59633d82b8e1b98a1b270c0e24332bd2f80e5bbf017b54268c951fd843172101813dc66c5c6eb5c5276adf4c4e5820d9a547fe02d8d7ac0b6794f050e23545 SHA512 1b9e3dfe7dca47a535328c9dab29128262075ac28b7ec18878704d244a27ec417c7d9c00b518dbaa782c2daccaa3affe4b8f9f60df19e1e9b4ca2c70fc2a2483
-DIST dolfin-2016.2.0.tar.gz 9702541 BLAKE2B 0e6b73419bbaf5b24e63d5b5347e9e8ee280b86868f02aadae06ee638053554b55277fecfe124982b99debc0402744cddb5aa81283d8413c5d5cde9c39cd12bc SHA512 1886513b433845c1026c37a7ac574d8bb7d08e896e5e54a0cca7f2ba3dde02b5c3551c005a408de151a915ca890ba8e65ebfd53abaef980132cc636c47f8f5fa
-DIST dolfin-2017.1.0.tar.gz 13264977 BLAKE2B 1fa0c0921196749e19582201cbf7ed19c38b59436fad01afc766dc2dc77387385d2765e844b62741481292652b4154035f811f454bda4e85e93bcd0b7fd1bab4 SHA512 60b6c2128b5249eb94551e23b3c1e2eb014af7336ddea629c8d496be0d3782bcdc03b494b6a12ba3fc948e8dcca8bffce412da1a7c7038464e5a747ec5430f94
diff --git a/sci-mathematics/dolfin/dolfin-0.9.9.ebuild b/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
deleted file mode 100644
index 4677e51b2..000000000
--- a/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils eutils python-single-r1
-
-DESCRIPTION="C++/Python interface of FEniCS"
-HOMEPAGE="https://launchpad.net/dolfin/"
-SRC_URI="https://launchpad.net/${PN}/0.x/${PV}/+download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cgal cholmod gmp mpi parmetis python scotch umfpack zlib"
-# scotch and parmetis require mpi; wait for EAPI 4
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- dev-libs/boost
- dev-libs/libxml2:2
- sci-libs/armadillo
- sci-mathematics/ufc
- python? (
- ${PYTHON_DEPS}
- dev-python/ufl[${PYTHON_USEDEP}]
- dev-python/ffc[${PYTHON_USEDEP}]
- dev-python/fiat[${PYTHON_USEDEP}]
- dev-python/instant[${PYTHON_USEDEP}]
- dev-python/viper[${PYTHON_USEDEP}]
- )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/"${P}"-find-armadillo.patch
-}
-
-pkg_setup() {
- mycmakeargs="${mycmakeargs}
- $(cmake-utils_use cgal DOLFIN_ENABLE_CGAL)
- $(cmake-utils_use cholmod DOLFIN_ENABLE_CHOLMOD)
- $(cmake-utils_use gmp DOLFIN_ENABLE_GMP)
- $(cmake-utils_use mpi DOLFIN_ENABLE_MPI)
- $(cmake-utils_use parmetis DOLFIN_ENABLE_PARMETIS)
- $(cmake-utils_use python DOLFIN_ENABLE_PYTHON)
- $(cmake-utils_use scotch DOLFIN_ENABLE_SCOTCH)
- $(cmake-utils_use umfpack DOLFIN_ENABLE_UMFPACK)
- $(cmake-utils_use zlib DOLFIN_ENABLE_ZLIB)"
-}
diff --git a/sci-mathematics/dolfin/dolfin-2016.2.0-r2.ebuild b/sci-mathematics/dolfin/dolfin-2016.2.0-r2.ebuild
deleted file mode 100644
index 4d5d8f716..000000000
--- a/sci-mathematics/dolfin/dolfin-2016.2.0-r2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils eutils python-single-r1
-
-DESCRIPTION="C++/Python interface of FEniCS"
-HOMEPAGE="https://bitbucket.org/fenics-project/dolfin"
-SRC_URI="https://bitbucket.org/fenics-project/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="hdf5 mpi parmetis petsc scotch trilinos umfpack zlib vtk"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- trilinos? ( mpi )"
-
-# Yes, swig is an RDEPEND
-DEPEND="
- ${PYTHON_DEPS}
- dev-cpp/eigen:3
- dev-lang/swig:0=
- dev-libs/boost:=
- dev-libs/libxml2:2
- ~dev-python/dijitso-${PV}[${PYTHON_USEDEP}]
- ~dev-python/ffc-${PV}[${PYTHON_USEDEP}]
- ~dev-python/fiat-${PV}[${PYTHON_USEDEP}]
- ~dev-python/instant-${PV}[${PYTHON_USEDEP}]
- dev-python/sympy
- ~dev-python/ufl-${PV}[${PYTHON_USEDEP}]
- virtual/blas
- virtual/lapack
- hdf5? ( sci-libs/hdf5[mpi=] )
- mpi? ( virtual/mpi )
- parmetis? ( sci-libs/parmetis[mpi(+)] )
- petsc? ( sci-mathematics/petsc[mpi=] )
- sci-libs/armadillo
- scotch? ( sci-libs/scotch )
- trilinos? ( sci-libs/trilinos )
- umfpack? (
- sci-libs/amd
- sci-libs/cholmod
- sci-libs/umfpack
- )
- vtk? ( sci-libs/vtk )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-trilinos-superlu.patch
-)
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- # *sigh*
- addpredict /proc/mtrr
- addpredict /sys/devices/system/cpu/
-
- mycmakeargs=(
- -DDOLFIN_ENABLE_CHOLMOD="$(usex umfpack)"
- -DDOLFIN_ENABLE_HDF5="$(usex hdf5)"
- -DDOLFIN_ENABLE_MPI="$(usex mpi)"
- -DDOLFIN_ENABLE_PARMETIS="$(usex parmetis)"
- -DDOLFIN_ENABLE_PETSC="$(usex petsc)"
- -DDOLFIN_ENABLE_PYTHON="yes"
- -DDOLFIN_ENABLE_SCOTCH="$(usex scotch)"
- -DDOLFIN_ENABLE_TRILINOS="$(usex trilinos)"
- -DDOLFIN_ENABLE_UMFPACK="$(usex umfpack)"
- -DDOLFIN_ENABLE_VTK="$(usex vtk)"
- -DDOLFIN_ENABLE_ZLIB="$(usex zlib)"
- )
- cmake-utils_src_configure
-}
diff --git a/sci-mathematics/dolfin/dolfin-2017.1.0.ebuild b/sci-mathematics/dolfin/dolfin-2017.1.0.ebuild
deleted file mode 100644
index 64e736315..000000000
--- a/sci-mathematics/dolfin/dolfin-2017.1.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
-
-inherit cmake-utils eutils python-single-r1
-
-DESCRIPTION="C++/Python interface of FEniCS"
-HOMEPAGE="https://bitbucket.org/fenics-project/dolfin"
-SRC_URI="https://bitbucket.org/fenics-project/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="hdf5 mpi parmetis petsc scotch trilinos umfpack zlib vtk"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- trilinos? ( mpi )"
-
-# Yes, swig is an RDEPEND
-DEPEND="
- ${PYTHON_DEPS}
- dev-cpp/eigen:3
- dev-lang/swig:0=
- dev-libs/boost:=
- dev-libs/libxml2:2
- ~dev-python/dijitso-${PV}[${PYTHON_USEDEP}]
- ~dev-python/ffc-${PV}[${PYTHON_USEDEP}]
- ~dev-python/fiat-${PV}[${PYTHON_USEDEP}]
- ~dev-python/instant-${PV}[${PYTHON_USEDEP}]
- dev-python/sympy
- ~dev-python/ufl-${PV}[${PYTHON_USEDEP}]
- virtual/blas
- virtual/lapack
- hdf5? ( sci-libs/hdf5[mpi=] )
- mpi? ( virtual/mpi )
- parmetis? ( sci-libs/parmetis[mpi(+)] )
- petsc? ( sci-mathematics/petsc[mpi=] )
- sci-libs/armadillo
- scotch? ( sci-libs/scotch )
- trilinos? ( sci-libs/trilinos )
- umfpack? (
- sci-libs/amd
- sci-libs/cholmod
- sci-libs/umfpack
- )
- vtk? ( sci-libs/vtk )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2016.2.0-trilinos-superlu.patch
-)
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- # *sigh*
- addpredict /proc/mtrr
- addpredict /sys/devices/system/cpu/
-
- mycmakeargs=(
- -DDOLFIN_ENABLE_CHOLMOD="$(usex umfpack)"
- -DDOLFIN_ENABLE_HDF5="$(usex hdf5)"
- -DDOLFIN_ENABLE_MPI="$(usex mpi)"
- -DDOLFIN_ENABLE_PARMETIS="$(usex parmetis)"
- -DDOLFIN_ENABLE_PETSC="$(usex petsc)"
- -DDOLFIN_ENABLE_PYTHON="yes"
- -DDOLFIN_ENABLE_SCOTCH="$(usex scotch)"
- -DDOLFIN_ENABLE_TRILINOS="$(usex trilinos)"
- -DDOLFIN_ENABLE_UMFPACK="$(usex umfpack)"
- -DDOLFIN_ENABLE_VTK="$(usex vtk)"
- -DDOLFIN_ENABLE_ZLIB="$(usex zlib)"
- )
- cmake-utils_src_configure
-}
diff --git a/sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch b/sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch
deleted file mode 100644
index 677a78aab..000000000
--- a/sci-mathematics/dolfin/files/dolfin-0.9.9-find-armadillo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur a/cmake/modules/FindArmadillo.cmake b/cmake/modules/FindArmadillo.cmake
---- a/cmake/modules/FindArmadillo.cmake 2010-09-02 02:49:57.000000000 +0200
-+++ b/cmake/modules/FindArmadillo.cmake 2010-12-15 14:21:34.810300165 +0100
-@@ -95,8 +95,8 @@
- #include <armadillo>
- int main()
- {
-- arma::mat A = arma::rand(4, 4);
-- arma::vec b = arma::rand(4);
-+ arma::mat A = arma::randu(4, 4);
-+ arma::vec b = arma::randu(4);
- arma::vec x = arma::solve(A, b);
- return 0;
- }
-@@ -112,8 +112,8 @@
- #include <armadillo>
- int main()
- {
-- arma::mat A = arma::rand(4, 4);
-- arma::vec b = arma::rand(4);
-+ arma::mat A = arma::randu(4, 4);
-+ arma::vec b = arma::randu(4);
- arma::vec x = arma::solve(A, b);
- return 0;
- }
diff --git a/sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch b/sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch
deleted file mode 100644
index 7282766fe..000000000
--- a/sci-mathematics/dolfin/files/dolfin-2016.2.0-trilinos-superlu.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/dolfin/CMakeLists.txt b/dolfin/CMakeLists.txt
-index 26bc21a..0caf7ca 100644
---- a/dolfin/CMakeLists.txt
-+++ b/dolfin/CMakeLists.txt
-@@ -2,6 +2,7 @@ set(DOLFIN_H dolfin.h)
- install(FILES ${DOLFIN_H} DESTINATION ${DOLFIN_INCLUDE_DIR}
- COMPONENT Development)
-
-+
- # Configure and install dolfin/common/version.h file
- string(REPLACE "+" "" DOLFIN_VERSION_MICRO_STRIPPED ${DOLFIN_VERSION_MICRO})
- configure_file(${DOLFIN_SOURCE_DIR}/dolfin/common/version.h.in
-@@ -12,6 +13,8 @@ install(FILES ${CMAKE_BINARY_DIR}/dolfin/common/version.h
- )
- include_directories(${CMAKE_BINARY_DIR})
-
-+include_directories(/usr/include/superlu)
-+
- #------------------------------------------------------------------------------
- # DOLFIN source directories
-
diff --git a/sci-mathematics/dolfin/metadata.xml b/sci-mathematics/dolfin/metadata.xml
deleted file mode 100644
index 26a0480f0..000000000
--- a/sci-mathematics/dolfin/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
-DOLFIN is the C++/Python interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations.
-</longdescription>
- <use>
- <flag name="cgal">Adds support for geometric algorithms with <pkg>sci-mathematics/cgal</pkg></flag>
- <flag name="cholmod">Adds support for sparse Cholesky factorization with <pkg>sci-libs/cholmod</pkg></flag>
- <flag name="hdf5">Adds support for <pkg>sci-libs/hdf5</pkg></flag>
- <flag name="parmetis">Adds support for parallel graph partitioning with <pkg>sci-libs/parmetis</pkg></flag>
- <flag name="petsc">Adds support for numerical linear algebra toolkit <pkg>sci-mathematics/petsc</pkg></flag>
- <flag name="scotch">Adds support for graph partitioning with <pkg>sci-libs/scotch</pkg></flag>
- <flag name="trilinos">Adds support for numerical linear algebra toolkit <pkg>sci-libs/trilinos</pkg></flag>
- <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
- <flag name="vtk">Adds support for the visualization toolkit <pkg>sci-libs/vtk</pkg></flag>
- </use>
- <upstream>
- <remote-id type="bitbucket">fenics-project/dolfin</remote-id>
- <remote-id type="launchpad">dolfin</remote-id>
- </upstream>
-</pkgmetadata>