aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/flocq/flocq-3.4.0-r1.ebuild')
-rw-r--r--sci-mathematics/flocq/flocq-3.4.0-r1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/sci-mathematics/flocq/flocq-3.4.0-r1.ebuild b/sci-mathematics/flocq/flocq-3.4.0-r1.ebuild
deleted file mode 100644
index f0e6c73a8..000000000
--- a/sci-mathematics/flocq/flocq-3.4.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multiprocessing
-
-DESCRIPTION="A floating-point formalization for the Coq system"
-HOMEPAGE="http://flocq.gforge.inria.fr/"
-SRC_URI="https://gforge.inria.fr/frs/download.php/file/38385/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=sci-mathematics/coq-8.7"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- sed -i Remakefile.in \
- -e "s:mkdir -p @libdir@:mkdir -p \${DESTDIR}@libdir@:g" \
- -e "s:cp \$f @libdir@:cp \$f \${DESTDIR}@libdir@:g"
-}
-
-src_configure() {
- econf --libdir="`coqc -where`/user-contrib/Flocq"
-}
-
-src_compile() {
- ./remake --jobs=$(makeopts_jobs) || die "emake failed"
-}
-
-src_install() {
- DESTDIR="${D}" ./remake install || die
- einstalldocs
-}