aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/ltl2ba')
-rw-r--r--sci-mathematics/ltl2ba/Manifest2
-rw-r--r--sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild20
-rw-r--r--sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild31
-rw-r--r--sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild31
4 files changed, 75 insertions, 9 deletions
diff --git a/sci-mathematics/ltl2ba/Manifest b/sci-mathematics/ltl2ba/Manifest
index 4d6528d6b..659c1c6e6 100644
--- a/sci-mathematics/ltl2ba/Manifest
+++ b/sci-mathematics/ltl2ba/Manifest
@@ -1 +1,3 @@
DIST ltl2ba-1.1.tar.gz 29629 BLAKE2B 06ba7f7b5e3c6b72d2f0ea3b991346c803669e24d66dc38e311109ee08ed6dcc72bfd9f2ebe0f8864b0f80f010a4438029f4f5dbbf0087469ca2d07cdfce6b3f SHA512 8d010e2bb59fa5d682a56a50133865da938fd3bfcde6386184880eec6989bc1b694d6af9146b4b708cefdcdbcf98248f87074b8c973ea8cab65d658b394ccf69
+DIST ltl2ba-1.2.tar.gz 33026 BLAKE2B f19359e33d4eeb4dde75425ed03d940c08f46dd265b1b9c6773807e7dca67fd44f694f685d4153ca786118e336fab736104a865c5d0e9883390fca694f72b492 SHA512 148ffb1b4dbe134b69c6e946a4a9f1a95a809bf36ef3533117eedeceb721dd4c8a3238bbda2de5782a79b7aee70e33adf6ff193917441092a1ccb4e56a53a655
+DIST ltl2ba-1.3.tar.gz 38265 BLAKE2B bd74d9b9e22589ac00fbaa15f745dd6371894f68b50f85507694648274d9391ad3a90cdf1ee6c342abbceb04d0e2eb5d71473d43969b469a933517cfcd1e16c1 SHA512 1bcef13d98879c083dc907939c652e694802ed91c33a5d90bbeb6fc22d6265a0b153932c5fb3f8557aad30582322c16d0be822bf4208f40faf9384b367a84aa6
diff --git a/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild b/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild
index 29609c146..6172bb985 100644
--- a/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild
+++ b/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild
@@ -1,29 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+inherit flag-o-matic
DESCRIPTION="Fast LTL to Buechi Automata Translation"
-HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/${PN}/"
+HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/ltl2ba"
SRC_URI="http://www.lsv.ens-cachan.fr/~gastin/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-src_compile() {
+src_prepare() {
+ default
sed -i Makefile \
-e "s/CC=gcc/#CC=gcc/g" \
- -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g"
+ -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g" || die
+}
+src_configure() {
+ append-cflags -fcommon
default
}
src_install() {
- dobin ltl2ba || die "dobin failed"
+ dobin ltl2ba
dodoc README
}
diff --git a/sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild b/sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild
new file mode 100644
index 000000000..0678dcf8e
--- /dev/null
+++ b/sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Fast LTL to Buechi Automata Translation"
+HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/ltl2ba"
+SRC_URI="http://www.lsv.ens-cachan.fr/~gastin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e "s/CC=gcc/#CC=gcc/g" \
+ -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g" || die
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
+src_install() {
+ dobin ltl2ba
+ dodoc README
+}
diff --git a/sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild b/sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild
new file mode 100644
index 000000000..0678dcf8e
--- /dev/null
+++ b/sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Fast LTL to Buechi Automata Translation"
+HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/ltl2ba"
+SRC_URI="http://www.lsv.ens-cachan.fr/~gastin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e "s/CC=gcc/#CC=gcc/g" \
+ -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g" || die
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
+src_install() {
+ dobin ltl2ba
+ dodoc README
+}