aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/mdp/mdp-3.3.ebuild')
-rw-r--r--sci-mathematics/mdp/mdp-3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/mdp/mdp-3.3.ebuild b/sci-mathematics/mdp/mdp-3.3.ebuild
new file mode 100644
index 000000000..2a6300391
--- /dev/null
+++ b/sci-mathematics/mdp/mdp-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1
+
+MY_P="${P/mdp/MDP}"
+MY_P="${MY_P/_rc/RC}"
+
+DESCRIPTION="Data processing framework in python"
+HOMEPAGE="http://mdp-toolkit.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/mdp-toolkit/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| (
+ >=dev-python/numpy-1.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.5.2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -c "import mdp;mdp.test()" || die
+}