aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/ChangeLog6
-rw-r--r--sci-mathematics/normaliz/Manifest6
-rw-r--r--sci-mathematics/normaliz/metadata.xml4
-rw-r--r--sci-mathematics/normaliz/normaliz-2.5.ebuild45
4 files changed, 59 insertions, 2 deletions
diff --git a/sci-mathematics/normaliz/ChangeLog b/sci-mathematics/normaliz/ChangeLog
index ad01373b7..de571395d 100644
--- a/sci-mathematics/normaliz/ChangeLog
+++ b/sci-mathematics/normaliz/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*normaliz-2.5 (05 Sep 2010)
+
+ 05 Sep 2010; Thomas Kahle <tom111@gmx.de> +normaliz-2.5.ebuild,
+ metadata.xml:
+ Bump to 2.5
+
14 Aug 2010; Christopher Schwan <cschwan@students.uni-mainz.de>
normaliz-2.2.ebuild:
Fixed SRC_URI - url has moved because upstream has released 2.5
diff --git a/sci-mathematics/normaliz/Manifest b/sci-mathematics/normaliz/Manifest
index 1728dc329..2b78bc320 100644
--- a/sci-mathematics/normaliz/Manifest
+++ b/sci-mathematics/normaliz/Manifest
@@ -1,4 +1,6 @@
DIST Normaliz2.2Linux32.zip 3712125 RMD160 0b223dc7996c5b3d1d4b2d009c718043ee7647e9 SHA1 e3b518164c8c6d22f6303b357a337fdc7dadae77 SHA256 9588942dc63a999070341f5b84e4eeab318bf5c610a5403d909793f9931f1263
+DIST Normaliz2.5.zip 4678783 RMD160 28f2c1aa0d88e83ef1e1f26f4a946e64e4871436 SHA1 a0095aa8f591fe485224deb73cce034e247472ab SHA256 31decc5172450ac918b97ff5cefb3b9b9b94e70d69cc4271962ba90f04ecde43
EBUILD normaliz-2.2.ebuild 781 RMD160 2a3e08479875f799f85a8116648c5f432903a2d9 SHA1 8db64bfd896ef270ce28be7ae23a2156f589a654 SHA256 d028cf3aa12706dd608512b7c847824bc9195d0cf8988eb6b18cda9b268779ec
-MISC ChangeLog 496 RMD160 a222a60ef01abb61935b1e869daa2e4281c75140 SHA1 eaa1ca128d2c1b50274a7889d1520755c46b0808 SHA256 e55722cbdfddd39a3051cba94027d84984203ce1dcbba9ede3a59bae19febd6f
-MISC metadata.xml 421 RMD160 3877e916b9efaf447139174c187eb04dc400e527 SHA1 5f83d6586e145e78f11bd4e2167d43c447fcbe40 SHA256 baee293f19fbe342b2976a565bb6c5c702cba12573ca03cd5baa62682f6c82da
+EBUILD normaliz-2.5.ebuild 1429 RMD160 142fb5d0920cbd3b10d5b970aa82a549ddb762c4 SHA1 48ac8938d8e06948c277b91fa51961d33640c80b SHA256 3dedba72f4b8137f79b709de613df86b48a4b8c09294540436e51aabb99c296d
+MISC ChangeLog 622 RMD160 d2e864da6b93e741e9e82d8af00abef6410bb6b9 SHA1 7cc3663799784dbf094a407cc2a8c37dc5c156d1 SHA256 e756fe14fef9fa902954603eac9aadb5a34f4d993e9a7b2b40ddeb8d52fe1345
+MISC metadata.xml 622 RMD160 061c75168a8d9b3ba45c3540c8a237f11dfd2870 SHA1 59cf06140e04d754796ef4f1c776ddb3fb57fde4 SHA256 d6a6dd3aa1f8749303d3072a15504b2fe5900cc947a16a14d9c3f61e06612075
diff --git a/sci-mathematics/normaliz/metadata.xml b/sci-mathematics/normaliz/metadata.xml
index 269daa4e4..2ec8c8221 100644
--- a/sci-mathematics/normaliz/metadata.xml
+++ b/sci-mathematics/normaliz/metadata.xml
@@ -6,6 +6,10 @@
<email>tom111@gmx.de</email>
<name>Thomas Kahle</name>
</maintainer>
+<use>
+ <flag name="extras"> Install the java-gui and Macaulay2/Singular packages.</flag>
+ <flag name="optimization">Accept upstream's choices for -O option, i.e. -O3 almost everywhere.</flag>
+</use>
<longdescription lang="en">
Normaliz is a (command line) tool for computations in affine monoids, vector configurations, lattice polytopes, and
rational cones.
diff --git a/sci-mathematics/normaliz/normaliz-2.5.ebuild b/sci-mathematics/normaliz/normaliz-2.5.ebuild
new file mode 100644
index 000000000..d1a5a041a
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Normaliz is a tool for computations in affine monoids and more"
+HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="http://www.mathematik.uni-osnabrueck.de/normaliz/Normaliz${PV}.zip"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc extras optimization"
+
+DEPEND="dev-libs/gmp[-nocxx]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Normaliz${PV}/source"
+
+src_prepare () {
+ if ! use optimization; then
+ sed -i "s/-O3 -funroll-loops/${CXXFLAGS}/" Makefile || die "sed on Makefile failed"
+ fi
+}
+
+src_install() {
+ dobin norm64 normbig || die "install failed"
+ if use doc; then
+ dodoc "../doc/Normaliz${PV}Documentation.pdf" || die "install failed"
+ fi
+ if use extras; then
+ elog "You have selected to install extras which consist of a gui jNormaliz.jar,"
+ elog "and Macaulay2 and Singular packages. These have been installed into "
+ elog "/usr/share/${PN}, and cannot be used without additional work. Please refer"
+ elog "to the homepages of the respective projects for additional information."
+ elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
+ elog "copies of these interface packages."
+ insinto "/usr/share/${PN}"
+ doins "../jNormaliz.jar"
+ doins "../Singular/normaliz.lib"
+ doins "../Macaulay2/Normaliz.m2"
+ fi
+} \ No newline at end of file