aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/pulp')
-rw-r--r--sci-mathematics/pulp/Manifest2
-rw-r--r--sci-mathematics/pulp/metadata.xml1
-rw-r--r--sci-mathematics/pulp/pulp-2.7.0.ebuild (renamed from sci-mathematics/pulp/pulp-2.4.ebuild)10
3 files changed, 6 insertions, 7 deletions
diff --git a/sci-mathematics/pulp/Manifest b/sci-mathematics/pulp/Manifest
index 8a93a1b47..abe10a827 100644
--- a/sci-mathematics/pulp/Manifest
+++ b/sci-mathematics/pulp/Manifest
@@ -1 +1 @@
-DIST pulp-2.4.tar.gz 54307777 BLAKE2B 6be924cb8cfbf49cf754791cdc7d6cf3c16559af776b52bcba3697aeca1228a148f8643a899653fbc18cfa3525aa73967ff835fb19c91cd57013cbe001281852 SHA512 e534660ac2b04833a4305fd2e7eb121bbb136d67379b0df662a5e5b47397ca72c43c568a9ae142877ef67a15af14990d455ea1d6c74ad5cdad5912e883fe6fb3
+DIST pulp-2.7.0.gh.tar.gz 28000854 BLAKE2B d2ec0f2e795ffc93051189e236ddefc92c1e0fbfc825f8bd32b6f8569c1e0ec290acaa418e93768587238ff25c3ae9a4d27457c7e5eb0635fc919ebb80b3de3b SHA512 be89eaeaac81cb79f6533b8764283f1f4ba85570f7626db6fa3e760124a26dcc1ee3ff3b293c67de2ed48083fe611ae0ca93db83da801456a34fe7cff816ba61
diff --git a/sci-mathematics/pulp/metadata.xml b/sci-mathematics/pulp/metadata.xml
index ce584d233..c86c3b501 100644
--- a/sci-mathematics/pulp/metadata.xml
+++ b/sci-mathematics/pulp/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">PuLP</remote-id>
+ <remote-id type="github">coin-or/pulp</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sci-mathematics/pulp/pulp-2.4.ebuild b/sci-mathematics/pulp/pulp-2.7.0.ebuild
index 1833c45a9..641a91622 100644
--- a/sci-mathematics/pulp/pulp-2.4.ebuild
+++ b/sci-mathematics/pulp/pulp-2.7.0.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Create MPS/LP files, call solvers, and present results"
HOMEPAGE="https://coin-or.github.io/pulp/"
-SRC_URI="https://github.com/coin-or/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/coin-or/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="BSD-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-RDEPEND="dev-python/amply[${PYTHON_USEDEP}]"
-
distutils_enable_tests setup.py
# ToDo: package theme
#distutils_enable_sphinx doc/source dev-python/sphinx_glpi_theme