aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cipi/cipi-1.0-r1.ebuild51
-rw-r--r--sci-mathematics/cipi/files/cipi-1.0-boost.patch11
-rw-r--r--sci-mathematics/frama-c/files/ocamlgraph185_compat.patch254
-rw-r--r--sci-mathematics/frama-c/frama-c-22.0.ebuild2
-rw-r--r--sci-mathematics/gap/Manifest2
-rw-r--r--sci-mathematics/gap/files/gap-4.11.0-autoconf.patch86
-rw-r--r--sci-mathematics/gap/gap-4.11.0.ebuild140
-rw-r--r--sci-mathematics/gap/metadata.xml30
-rw-r--r--sci-mathematics/lie/lie-2.2.2.ebuild2
-rw-r--r--sci-mathematics/ltl2ba/Manifest2
-rw-r--r--sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild31
-rw-r--r--sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild31
-rw-r--r--sci-mathematics/pulp/pulp-2.7.0.ebuild2
-rw-r--r--sci-mathematics/scilab-bin/Manifest1
-rw-r--r--sci-mathematics/scilab-bin/scilab-bin-2023.1.0.ebuild78
15 files changed, 208 insertions, 515 deletions
diff --git a/sci-mathematics/cipi/cipi-1.0-r1.ebuild b/sci-mathematics/cipi/cipi-1.0-r1.ebuild
new file mode 100644
index 000000000..6cd189e33
--- /dev/null
+++ b/sci-mathematics/cipi/cipi-1.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Computing information projections iteratively"
+HOMEPAGE="https://github.com/tom111/cipi"
+SRC_URI="https://github.com/tom111/cipi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+DEPEND="
+ dev-libs/boost:=
+ doc? ( virtual/latex-base )"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README"
+
+CMAKE_IN_SOURCE_BUILD="yes"
+
+PATCHES=(
+ "${FILESDIR}/${P}-boost.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ append-ldflags -Wl,--copy-dt-needed-entries
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_DOC=$(usex doc ON OFF)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog
+ elog "The sample PARAM file has been installed to /usr/share/${PN}-${PV}"
+ elog
+ if use doc; then
+ elog "A pdf manual has been installed to /usr/share/${PN}-${PV}"
+ fi
+}
diff --git a/sci-mathematics/cipi/files/cipi-1.0-boost.patch b/sci-mathematics/cipi/files/cipi-1.0-boost.patch
new file mode 100644
index 000000000..66aa9fd3f
--- /dev/null
+++ b/sci-mathematics/cipi/files/cipi-1.0-boost.patch
@@ -0,0 +1,11 @@
+--- a/src/CMakeLists.txt 2024-02-16 21:36:58.808186061 +0100
++++ b/src/CMakeLists.txt 2024-02-16 21:36:55.288131610 +0100
+@@ -8,7 +8,7 @@
+ Message("Boost found" ${Boost_LIBRARY_DIR})
+ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIR})
+ #MESSAGE("Boost was found" ${Boost_INCLUDE_DIR})
+- TARGET_LINK_LIBRARIES (cipi boost_thread-mt)
++ TARGET_LINK_LIBRARIES (cipi boost_thread)
+ ENDIF (Boost_FOUND)
+
+ INSTALL(PROGRAMS cipi DESTINATION bin)
diff --git a/sci-mathematics/frama-c/files/ocamlgraph185_compat.patch b/sci-mathematics/frama-c/files/ocamlgraph185_compat.patch
deleted file mode 100644
index 798d17fd3..000000000
--- a/sci-mathematics/frama-c/files/ocamlgraph185_compat.patch
+++ /dev/null
@@ -1,254 +0,0 @@
-From: Mehdi Dogguy <mehdi@debian.org>
-Date: Sun, 27 Apr 2014 13:46:16 +0200
-Subject: Port to OCamlgraph 1.8.5
-
----
- src/impact/reason_graph.ml | 2 +-
- src/kernel/stmts_graph.ml | 10 +++++-----
- src/logic/property_status.ml | 8 ++++----
- src/misc/service_graph.ml | 4 ++--
- src/pdg_types/pdgTypes.ml | 6 +++---
- src/postdominators/print.ml | 2 +-
- src/semantic_callgraph/register.ml | 4 ++--
- src/slicing/printSlice.ml | 10 +++++-----
- src/syntactic_callgraph/register.ml | 4 ++--
- src/wp/cil2cfg.ml | 12 ++++++------
- 10 files changed, 31 insertions(+), 31 deletions(-)
-
-diff --git a/src/impact/reason_graph.ml b/src/impact/reason_graph.ml
-index eabacb0..ce19b4a 100644
---- a/src/impact/reason_graph.ml
-+++ b/src/impact/reason_graph.ml
-@@ -139,7 +139,7 @@ module Printer (X: AdditionalInfo) = struct
-
- let graph_attributes _ = [`Label "Impact graph"]
-
-- let default_vertex_attributes _g = [`Style [`Filled]; `Shape `Box]
-+ let default_vertex_attributes _g = [`Style `Filled; `Shape `Box]
- let default_edge_attributes _g = []
-
- let vertex_attributes v =
-diff --git a/src/kernel/stmts_graph.ml b/src/kernel/stmts_graph.ml
-index a8fe121..16059c3 100644
---- a/src/kernel/stmts_graph.ml
-+++ b/src/kernel/stmts_graph.ml
-@@ -157,12 +157,12 @@ module TP = struct
-
- let vertex_attributes s =
- match s.skind with
-- | Loop _ -> [`Color 0xFF0000; `Style [`Filled]]
-- | If _ -> [`Color 0x00FF00; `Style [`Filled]; `Shape `Diamond]
-- | Return _ -> [`Color 0x0000FF; `Style [`Filled]]
-+ | Loop _ -> [`Color 0xFF0000; `Style `Filled]
-+ | If _ -> [`Color 0x00FF00; `Style `Filled; `Shape `Diamond]
-+ | Return _ -> [`Color 0x0000FF; `Style `Filled]
- | Block _ -> [`Shape `Box; `Fontsize 8]
-- | Goto _ -> [`Shape `Diamond; `Color 0x00FFFF ; `Style [`Filled]]
-- | Instr (Skip _) -> [`Color 0x00FFFF ; `Style [`Filled]]
-+ | Goto _ -> [`Shape `Diamond; `Color 0x00FFFF ; `Style `Filled]
-+ | Instr (Skip _) -> [`Color 0x00FFFF ; `Style `Filled]
- | _ -> []
- let default_vertex_attributes _ = []
-
-diff --git a/src/logic/property_status.ml b/src/logic/property_status.ml
-index f7c278d..47485f6 100644
---- a/src/logic/property_status.ml
-+++ b/src/logic/property_status.ml
-@@ -1481,12 +1481,12 @@ module Consolidation_graph = struct
- let s = get_status p in
- let color = status_color p s in
- let style = match s with
-- | Never_tried -> [`Style [`Bold]; `Width 0.8 ]
-- | _ -> [`Style [`Filled]]
-+ | Never_tried -> [`Style `Bold; `Width 0.8 ]
-+ | _ -> [`Style `Filled]
- in
- style @ [ label v; `Color color; `Shape `Box ]
- | Emitter _ as v ->
-- [ label v; `Shape `Diamond; `Color 0xb0c4de; `Style [`Filled] ]
-+ [ label v; `Shape `Diamond; `Color 0xb0c4de; `Style `Filled ]
- | Tuning_parameter _ as v ->
- [ label v; (*`Style `Dotted;*) `Color 0xb0c4de; ]
- (*| Correctness_parameter _ (*as v*) -> assert false (*[ label v; `Color 0xb0c4de ]*)*)
-@@ -1495,7 +1495,7 @@ module Consolidation_graph = struct
- | None -> []
- | Some s ->
- let c = emitted_status_color s in
-- [ `Color c; `Fontcolor c; `Style [`Bold] ]
-+ [ `Color c; `Fontcolor c; `Style `Bold ]
-
- let default_vertex_attributes _ = []
- let default_edge_attributes _ = []
-diff --git a/src/misc/service_graph.ml b/src/misc/service_graph.ml
-index 4f866c5..d158028 100644
---- a/src/misc/service_graph.ml
-+++ b/src/misc/service_graph.ml
-@@ -289,7 +289,7 @@ Src root:%s in %s (is_root:%b) Dst:%s in %s (is_root:%b) [2d case]"
- color e
- else
- match CallG.E.label e with
-- | Inter_services -> [ `Style [`Invis] ]
-+ | Inter_services -> [ `Style `Invis ]
- | Inter_functions | Both -> color e
-
- let default_edge_attributes _ = []
-@@ -303,7 +303,7 @@ Src root:%s in %s (is_root:%b) Dst:%s in %s (is_root:%b) [2d case]"
- sg_attributes =
- [ `Label ("S " ^ cs);
- `Color (Extlib.number_to_color id);
-- `Style [`Bold] ] }
-+ `Style `Bold ] }
-
- end
-
-diff --git a/src/pdg_types/pdgTypes.ml b/src/pdg_types/pdgTypes.ml
-index 05754e4..74cdebf 100644
---- a/src/pdg_types/pdgTypes.ml
-+++ b/src/pdg_types/pdgTypes.ml
-@@ -626,7 +626,7 @@ module Pdg = struct
-
- let graph_attributes _ = [`Rankdir `TopToBottom ]
-
-- let default_vertex_attributes _ = [`Style [`Filled]]
-+ let default_vertex_attributes _ = [`Style `Filled]
- let vertex_name v = string_of_int (Node.id v)
-
- let vertex_attributes v =
-@@ -711,13 +711,13 @@ module Pdg = struct
- if Dpd.is_ctrl d then (`Arrowtail `Odot)::attrib else attrib
- in
- let attrib =
-- if Dpd.is_addr d then (`Style [`Dotted])::attrib else attrib
-+ if Dpd.is_addr d then (`Style `Dotted)::attrib else attrib
- in
- attrib
-
- let get_subgraph v =
- let mk_subgraph name attrib =
-- let attrib = (`Style [`Filled]) :: attrib in
-+ let attrib = (`Style `Filled) :: attrib in
- Some { Graph.Graphviz.DotAttributes.sg_name= name;
- sg_parent = None;
- sg_attributes = attrib }
-diff --git a/src/postdominators/print.ml b/src/postdominators/print.ml
-index f2e3a25..15f4ff2 100644
---- a/src/postdominators/print.ml
-+++ b/src/postdominators/print.ml
-@@ -63,7 +63,7 @@ module Printer = struct
-
- let graph_attributes (title, _) = [`Label title]
-
-- let default_vertex_attributes _g = [`Style [`Filled]]
-+ let default_vertex_attributes _g = [`Style `Filled]
- let default_edge_attributes _g = []
-
- let vertex_attributes (s, has_postdom) =
-diff --git a/src/semantic_callgraph/register.ml b/src/semantic_callgraph/register.ml
-index 1c79dcc..071f061 100644
---- a/src/semantic_callgraph/register.ml
-+++ b/src/semantic_callgraph/register.ml
-@@ -102,8 +102,8 @@ module Service =
- let name = Kernel_function.get_name
- let attributes v =
- [ `Style
-- [if Kernel_function.is_definition v then `Bold
-- else `Dotted] ]
-+ (if Kernel_function.is_definition v then `Bold
-+ else `Dotted) ]
- let entry_point () =
- try Some (fst (Globals.entry_point ()))
- with Globals.No_such_entry_point _ -> None
-diff --git a/src/slicing/printSlice.ml b/src/slicing/printSlice.ml
-index c5363f9..211e0bb 100644
---- a/src/slicing/printSlice.ml
-+++ b/src/slicing/printSlice.ml
-@@ -227,7 +227,7 @@ module PrintProject = struct
-
- let graph_attributes (name, _) = [`Label name]
-
-- let default_vertex_attributes _ = [`Style [`Filled]]
-+ let default_vertex_attributes _ = [`Style `Filled]
-
- let vertex_name v = match v with
- | Src fi -> SlicingMacros.fi_name fi
-@@ -280,16 +280,16 @@ module PrintProject = struct
-
- let edge_attributes (e, call) =
- let attrib = match e with
-- | (Src _, Src _) -> [`Style [`Invis]]
-- | (OptSliceCallers _, _) -> [`Style [`Invis]]
-- | (_, OptSliceCallers _) -> [`Style [`Invis]]
-+ | (Src _, Src _) -> [`Style `Invis]
-+ | (OptSliceCallers _, _) -> [`Style `Invis]
-+ | (_, OptSliceCallers _) -> [`Style `Invis]
- | _ -> []
- in match call with None -> attrib
- | Some call -> (`Label (string_of_int call.sid)):: attrib
-
- let get_subgraph v =
- let mk_subgraph name attrib =
-- let attrib = (*(`Label name) ::*) (`Style [`Filled]) :: attrib in
-+ let attrib = (*(`Label name) ::*) (`Style `Filled) :: attrib in
- Some { Graph.Graphviz.DotAttributes.sg_name= name;
- sg_parent = None;
- sg_attributes = attrib }
-diff --git a/src/syntactic_callgraph/register.ml b/src/syntactic_callgraph/register.ml
-index d4669c4..d41980e 100644
---- a/src/syntactic_callgraph/register.ml
-+++ b/src/syntactic_callgraph/register.ml
-@@ -37,8 +37,8 @@ module Service =
- let name v = nodeName v.cnInfo
- let attributes v =
- [ match v.cnInfo with
-- | NIVar (_,b) when not !b -> `Style [`Dotted]
-- | _ -> `Style [`Bold] ]
-+ | NIVar (_,b) when not !b -> `Style `Dotted
-+ | _ -> `Style `Bold ]
- let equal v1 v2 = id v1 = id v2
- let compare v1 v2 =
- let i1 = id v1 in
-diff --git a/src/wp/cil2cfg.ml b/src/wp/cil2cfg.ml
-index 6d8cf09..ba5f410 100644
---- a/src/wp/cil2cfg.ml
-+++ b/src/wp/cil2cfg.ml
-@@ -1278,9 +1278,9 @@ module Printer (PE : sig val edge_txt : edge -> string end) = struct
- | Vstart | Vend | Vexit -> [`Color 0x0000FF; `Shape `Doublecircle]
- | VfctIn | VfctOut -> [`Color 0x0000FF; `Shape `Box]
- | VblkIn _ | VblkOut _ -> [`Shape `Box]
-- | Vloop _ | Vloop2 _ -> [`Color 0xFF0000; `Style [`Filled]]
-+ | Vloop _ | Vloop2 _ -> [`Color 0xFF0000; `Style `Filled]
- | Vtest _ | Vswitch _ ->
-- [`Color 0x00FF00; `Style [`Filled]; `Shape `Diamond]
-+ [`Color 0x00FF00; `Style `Filled; `Shape `Diamond]
- | Vcall _ | Vstmt _ -> []
- in (`Label (String.escaped label))::attr
-
-@@ -1290,15 +1290,15 @@ module Printer (PE : sig val edge_txt : edge -> string end) = struct
- let attr = [] in
- let attr = (`Label (String.escaped (PE.edge_txt e)))::attr in
- let attr =
-- if is_back_edge e then (`Constraint false)::(`Style [`Bold])::attr
-+ if is_back_edge e then (`Constraint false)::(`Style `Bold)::attr
- else attr
- in
- let attr = match (edge_type e) with
- | Ethen | EbackThen -> (`Color 0x00FF00)::attr
- | Eelse | EbackElse -> (`Color 0xFF0000)::attr
-- | Ecase [] -> (`Color 0x0000FF)::(`Style [`Dashed])::attr
-+ | Ecase [] -> (`Color 0x0000FF)::(`Style `Dashed)::attr
- | Ecase _ -> (`Color 0x0000FF)::attr
-- | Enext -> (`Style [`Dotted])::attr
-+ | Enext -> (`Style `Dotted)::attr
- | Eback -> attr (* see is_back_edge above *)
- | Enone -> attr
- in
-@@ -1308,7 +1308,7 @@ module Printer (PE : sig val edge_txt : edge -> string end) = struct
-
- let get_subgraph v =
- let mk_subgraph name attrib =
-- let attrib = (`Style [`Filled]) :: attrib in
-+ let attrib = (`Style `Filled) :: attrib in
- Some { Graph.Graphviz.DotAttributes.sg_name= name;
- sg_parent = None;
- sg_attributes = attrib }
---
diff --git a/sci-mathematics/frama-c/frama-c-22.0.ebuild b/sci-mathematics/frama-c/frama-c-22.0.ebuild
index a64c05e82..aaf815f4f 100644
--- a/sci-mathematics/frama-c/frama-c-22.0.ebuild
+++ b/sci-mathematics/frama-c/frama-c-22.0.ebuild
@@ -20,7 +20,7 @@ RESTRICT="strip"
DEPEND="
>=dev-lang/ocaml-3.12.1[ocamlopt?]
- >=dev-ml/ocamlgraph-1.8.5[gtk(-)?,ocamlopt?]
+ >=dev-ml/ocamlgraph-1.8.5[ocamlopt?]
dev-ml/zarith
dev-ml/yojson
sci-mathematics/coq
diff --git a/sci-mathematics/gap/Manifest b/sci-mathematics/gap/Manifest
deleted file mode 100644
index b64b9f6e7..000000000
--- a/sci-mathematics/gap/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST gap-4.11.0-core-packages.tar.gz 53096715 BLAKE2B 1cfec307efe95a91869e9bf4d3947dd9010a26a0cbe2c317eafb5f5402068f00f8f1518e995c92a7827e9a0fa387fc8db5dc6dd2f6cc5a1b24df1754c1e96c7f SHA512 e4ac9ffd7c33121af46ec3f255634c47efb8445429b570a8ad3c8784688f7e966d48c8f74aa50d039608974bd93e05bf61497df02e4b42f5577651c88c3884d4
-DIST gap-4.11.0-core.tar.bz2 13467788 BLAKE2B a0e1415bb2a6725f4ef6283e4823e1c1cd4d9813f981f5e6d02554fe2ae3ad05793320239e70d6412a4d4722da436bacd4fe127c79b9ec891ccbdfa3cd7c2d12 SHA512 94d5451e76ddcea33a5f83b1082f9b5d0ecb83f30491bdf510338f1eecea9faa868312cb682b5dd08c2b71c03cd3ca3f837df98fb96e52c8b89ab2443402ee49
diff --git a/sci-mathematics/gap/files/gap-4.11.0-autoconf.patch b/sci-mathematics/gap/files/gap-4.11.0-autoconf.patch
deleted file mode 100644
index b220f3ada..000000000
--- a/sci-mathematics/gap/files/gap-4.11.0-autoconf.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 938fcd3..b3b2340 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -6,6 +6,7 @@ AC_INIT([GAP], [4.dev], [support@gap-system.org], [gap], [https://www.gap-system
-
- AC_CONFIG_SRCDIR([src/gap.c])
- AC_CONFIG_AUX_DIR([cnf])
-+AC_CONFIG_MACRO_DIR([m4])
-
- AC_CONFIG_HEADERS([gen/config.h:src/config.h.in])
- AC_CONFIG_COMMANDS([gen/stamp-h], [echo timestamp > gen/stamp-h])
-@@ -207,29 +208,41 @@ dnl User setting: Debug mode (off by default)
- dnl
- AC_ARG_ENABLE([debug],
- [AS_HELP_STRING([--enable-debug], [enable debug mode])],
-- [AC_DEFINE([GAP_KERNEL_DEBUG], [1], [define if building in debug mode])
-- AC_DEFINE([GAP_PRINT_BACKTRACE], [1], [to enable backtraces upon crashes])],
-+ [],
- [enable_debug=no]
- )
- AC_MSG_CHECKING([whether to enable debug mode])
- AC_MSG_RESULT([$enable_debug])
-
-+AS_IF([test "x$enable_debug" != "xno"],
-+ [AC_DEFINE([GAP_KERNEL_DEBUG], [1], [define if building in debug mode])
-+ AC_DEFINE([GAP_PRINT_BACKTRACE], [1], [to enable backtraces upon crashes])],
-+)
-+
- AC_ARG_ENABLE([memory-checking],
- [AS_HELP_STRING([--enable-memory-checking], [enable memory checking])],
-- [AC_DEFINE([GAP_MEM_CHECK], [1], [define if building with memory checking])],
-+ [],
- [enable_memory_checking=no]
- )
- AC_MSG_CHECKING([whether to enable memory checking])
- AC_MSG_RESULT([$enable_memory_checking])
-
-+AS_IF([test "x$enable_memory_checking" != "xno"],
-+ [AC_DEFINE([GAP_MEM_CHECK], [1], [define if building with memory checking])]
-+)
-+
- AC_ARG_ENABLE([valgrind],
- [AS_HELP_STRING([--enable-valgrind], [enable valgrind extensions to GASMAN])],
-- [AC_DEFINE([GAP_MEMORY_CANARY], [1], [define if building with valgrind extensions])],
-+ [],
- [enable_valgrind=no]
- )
- AC_MSG_CHECKING([whether to enable valgrind extensions to GASMAN])
- AC_MSG_RESULT([$enable_valgrind])
-
-+AS_IF([test "x$enable_valgrind" != "xno"],
-+ [AC_DEFINE([GAP_MEMORY_CANARY], [1], [define if building with valgrind extensions])]
-+)
-+
- if test "x$enable_valgrind" != "xno" -a "x$enable_memory_checking" != "xno"; then
- AC_MSG_ERROR([--enable-valgrind and --enable-memory-checking cannot be used at the same time])
- fi
-@@ -549,10 +562,9 @@ AS_IF([test "x$with_gc" = xboehm],
- #
- # As a side benefit, users do not have to worry about installing dependencies.
-
-- BUILD_LIBATOMIC_OPS=yes
-- LIBATOMIC_OPS_CPPFLAGS='-I${abs_builddir}/extern/install/libatomic_ops/include'
-- LIBATOMIC_OPS_LDFLAGS='${abs_builddir}/extern/install/libatomic_ops/lib/libatomic_ops.la'
-- LIBATOMIC_OPS_LIBS=
-+ BUILD_LIBATOMIC_OPS=no
-+ #PKG_CHECK_MODULES([LIBATOMIC_OPS], [atomic_ops])
-+
- AC_SUBST([BUILD_LIBATOMIC_OPS])
- AC_SUBST([LIBATOMIC_OPS_CPPFLAGS])
- AC_SUBST([LIBATOMIC_OPS_LDFLAGS])
-@@ -561,11 +573,8 @@ AS_IF([test "x$with_gc" = xboehm],
- ATOMIC_OPS_CFLAGS=$LIBATOMIC_OPS_CPPFLAGS
- ATOMIC_OPS_LIBS=$LIBATOMIC_OPS_LDFLAGS
-
--
-- BUILD_BOEHM_GC=yes
-- BOEHM_GC_CPPFLAGS='-I${abs_builddir}/extern/install/gc/include'
-- BOEHM_GC_LDFLAGS='${abs_builddir}/extern/install/gc/lib/libgc.la'
-- BOEHM_GC_LIBS=
-+ BUILD_BOEHM_GC=no
-+ #PKG_CHECK_MODULES([BOEHM_GC], [bdw-gc])
- AC_SUBST([BUILD_BOEHM_GC])
- AC_SUBST([BOEHM_GC_CPPFLAGS])
- AC_SUBST([BOEHM_GC_LDFLAGS])
diff --git a/sci-mathematics/gap/gap-4.11.0.ebuild b/sci-mathematics/gap/gap-4.11.0.ebuild
deleted file mode 100644
index d94a02143..000000000
--- a/sci-mathematics/gap/gap-4.11.0.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit autotools python-any-r1
-
-DESCRIPTION="Computational discrete algebra system - minimal GAP core system"
-HOMEPAGE="https://www.gap-system.org/"
-SRC_URI="https://github.com/gap-system/gap/releases/download/v${PV}/gap-${PV}-core.tar.bz2
- https://github.com/gap-system/gap/releases/download/v${PV}/packages-required-v${PV}.tar.gz -> ${P}-core-packages.tar.gz
-"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64"
-# broken HPC and boehm
-IUSE="boehm debug hpc julia julia-gc memcheck valgrind"
-REQUIRED_USE="valgrind? ( memcheck ) julia-gc? ( julia ) hpc? ( boehm )"
-
-RDEPEND+="
- dev-libs/gmp
- net-libs/zeromq
- sci-libs/cddlib
- sys-libs/readline
- sys-libs/zlib
- julia? ( || (
- dev-lang/julia
- dev-lang/julia-bin:*
- ) )
- valgrind? ( dev-util/valgrind )
-"
-DEPEND+="${RDEPEND}"
-BDEPEND+="${PYTHON_DEPS}"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.11.0-autoconf.patch )
-
-pkg_setup() {
- if use valgrind; then
- elog "If you enable the use of valgrind duing building"
- elog "be sure that you have enabled the proper flags"
- elog "in gcc to support it:"
- elog "https://wiki.gentoo.org/wiki/Debugging#Valgrind"
- fi
-}
-
-src_unpack() {
- default
- mkdir -p "${S}"/pkg || die
- mv "${WORKDIR}"/{GAPDoc*,primgrp*,SmallGrp*,transgrp*} "${S}"/pkg || die
-}
-
-src_prepare() {
- default
- eautoreconf -f -i
-
- # use GNUmakefile
- rm Makefile || die
-
- # make sure of no external gmp/zlib being build
- # gap uses bundled libatomic_ops and boehm-gc
- rm -rf extern || die
-
- # this test takes TOO long
- rm tst/teststandard/opers/AutomorphismGroup.tst || die
-}
-
-src_configure() {
- addwrite /proc/self
- local myconf=(
- --enable-shared
- --disable-static
- --with-gmp
- --with-zlib
- --with-readline
- --enable-popcnt
- $(use_enable memcheck memory-checking)
- $(use_enable valgrind)
- $(use_enable hpc hpcgap)
- $(use_enable debug)
- $(use_with julia)
- )
- # garbage collector settings
- if use boehm; then
- myconf+=( --with-gc=boehm )
- elif use julia-gc; then
- myconf+=( --with-gc=julia )
- else
- myconf+=( --with-gc=gasman )
- fi
-
- # only supporting amd64 builds
- econf ${myconf[@]} ABI=64
-}
-
-src_test() {
- emake testinstall testlibgap
-}
-
-src_install() {
- # upstream has no install function
- # we try to simulate on as best as we can
-
- dodoc README{,.buildsys,.hpcgap}.md \
- CHANGES.md CITATION
-
- sed -e "s:^abs_top_builddir=.*$:abs_top_builddir=\"${EPREFIX}/usr/share/gap\":" \
- -e "s:^abs_top_srcdir=.*$:abs_top_srcdir=\"${EPREFIX}/usr/share/gap\":" \
- -i gac || die
- dobin gac
-
- exeinto /usr/share/gap/
- doexe gap
-
- cat <<-EOF > gap.sh || die
- #!/bin/sh
- exec "${EPREFIX}"/usr/share/gap/gap -l "${EPREFIX}"/usr/share/gap "\$@"
- EOF
- newbin gap.sh gap
-
- dolib.so .libs/libgap.so*
-
- dodir /usr/include/gap
- cp -a src/*.h gen/*.h "${ED}"/usr/include/gap || die
- if use hpc; then
- dodir /usr/include/gap/hpc
- cp -a src/hpc/*.h "${ED}"/usr/include/gap/hpc || die
- fi
-
- cp -a doc grp lib libtool pkg "${ED}"/usr/share/gap || die
-
- sed -e "s:${S}:${EPREFIX}/usr/share/gap:g" -i sysinfo.gap
- insinto /usr/share/gap
- doins sysinfo.gap*
-
- # remove objects and static lib files
- find "${ED}" \( -name "*.o" -o -name "*.a" -o -name "*.la" \) \
- -delete || die
-}
diff --git a/sci-mathematics/gap/metadata.xml b/sci-mathematics/gap/metadata.xml
deleted file mode 100644
index f1f953b82..000000000
--- a/sci-mathematics/gap/metadata.xml
+++ /dev/null
@@ -1,30 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>gentoo@aisha.cc</email>
- <name>Aisha Tammy</name>
- </maintainer>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
- Groups, Algorithms, Programming is a system for computational
- discrete algebra, with particular emphasis on Computational Group
- Theory. GAP provides a programming language, a library of thousands
- of functions implementing algebraic algorithms written in the GAP
- language as well as large data libraries of algebraic objects. GAP
- is used in research and teaching for studying groups and their
- representations, rings, vector spaces, algebras, combinatorial
- structures, and more.
- </longdescription>
- <use>
- <flag name="boehm">Use <pkg>dev-libs/boehm-gc</pkg> as garbage collector</flag>
- <flag name="hpc">Build gap with multithreading and parallel process support</flag>
- <flag name="julia">Build julia bindings</flag>
- <flag name="julia-gc">Use the julia garbage collector</flag>
- <flag name="memcheck">Enable memory checking</flag>
- <flag name="valgrind">Build symbols to be used by valgrind</flag>
- </use>
-</pkgmetadata>
diff --git a/sci-mathematics/lie/lie-2.2.2.ebuild b/sci-mathematics/lie/lie-2.2.2.ebuild
index 9577bf240..173e0715e 100644
--- a/sci-mathematics/lie/lie-2.2.2.ebuild
+++ b/sci-mathematics/lie/lie-2.2.2.ebuild
@@ -21,7 +21,7 @@ RDEPEND="
sys-libs/ncurses:=
"
DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}
+BDEPEND="
sys-devel/bison
"
diff --git a/sci-mathematics/ltl2ba/Manifest b/sci-mathematics/ltl2ba/Manifest
index 4d6528d6b..659c1c6e6 100644
--- a/sci-mathematics/ltl2ba/Manifest
+++ b/sci-mathematics/ltl2ba/Manifest
@@ -1 +1,3 @@
DIST ltl2ba-1.1.tar.gz 29629 BLAKE2B 06ba7f7b5e3c6b72d2f0ea3b991346c803669e24d66dc38e311109ee08ed6dcc72bfd9f2ebe0f8864b0f80f010a4438029f4f5dbbf0087469ca2d07cdfce6b3f SHA512 8d010e2bb59fa5d682a56a50133865da938fd3bfcde6386184880eec6989bc1b694d6af9146b4b708cefdcdbcf98248f87074b8c973ea8cab65d658b394ccf69
+DIST ltl2ba-1.2.tar.gz 33026 BLAKE2B f19359e33d4eeb4dde75425ed03d940c08f46dd265b1b9c6773807e7dca67fd44f694f685d4153ca786118e336fab736104a865c5d0e9883390fca694f72b492 SHA512 148ffb1b4dbe134b69c6e946a4a9f1a95a809bf36ef3533117eedeceb721dd4c8a3238bbda2de5782a79b7aee70e33adf6ff193917441092a1ccb4e56a53a655
+DIST ltl2ba-1.3.tar.gz 38265 BLAKE2B bd74d9b9e22589ac00fbaa15f745dd6371894f68b50f85507694648274d9391ad3a90cdf1ee6c342abbceb04d0e2eb5d71473d43969b469a933517cfcd1e16c1 SHA512 1bcef13d98879c083dc907939c652e694802ed91c33a5d90bbeb6fc22d6265a0b153932c5fb3f8557aad30582322c16d0be822bf4208f40faf9384b367a84aa6
diff --git a/sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild b/sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild
new file mode 100644
index 000000000..0678dcf8e
--- /dev/null
+++ b/sci-mathematics/ltl2ba/ltl2ba-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Fast LTL to Buechi Automata Translation"
+HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/ltl2ba"
+SRC_URI="http://www.lsv.ens-cachan.fr/~gastin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e "s/CC=gcc/#CC=gcc/g" \
+ -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g" || die
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
+src_install() {
+ dobin ltl2ba
+ dodoc README
+}
diff --git a/sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild b/sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild
new file mode 100644
index 000000000..0678dcf8e
--- /dev/null
+++ b/sci-mathematics/ltl2ba/ltl2ba-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Fast LTL to Buechi Automata Translation"
+HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/ltl2ba"
+SRC_URI="http://www.lsv.ens-cachan.fr/~gastin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e "s/CC=gcc/#CC=gcc/g" \
+ -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g" || die
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
+src_install() {
+ dobin ltl2ba
+ dodoc README
+}
diff --git a/sci-mathematics/pulp/pulp-2.7.0.ebuild b/sci-mathematics/pulp/pulp-2.7.0.ebuild
index 37952675f..641a91622 100644
--- a/sci-mathematics/pulp/pulp-2.7.0.ebuild
+++ b/sci-mathematics/pulp/pulp-2.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
diff --git a/sci-mathematics/scilab-bin/Manifest b/sci-mathematics/scilab-bin/Manifest
index d4c0e32f7..6029dc30e 100644
--- a/sci-mathematics/scilab-bin/Manifest
+++ b/sci-mathematics/scilab-bin/Manifest
@@ -1 +1,2 @@
+DIST scilab-2023.1.0.bin.x86_64-linux-gnu.tar.xz 182801620 BLAKE2B 19847145a8d70550afa77591854aa651ee5fe23f9998eee21c11acdd4112397fb5e2e82c6bc7edbc2f808048f70905dc0df37db00c43b5794bf304e9a0807ca4 SHA512 af0f71d270513f283ac732e2004094854a117ce4550c5ab579eda5c5ec52bde76a8fa5dd7649db84d68d43124524342f2fdc5f1ba269a60a3930c578ef3391f8
DIST scilab-6.1.1.bin.linux-x86_64.tar.gz 215840619 BLAKE2B dcfb88f2488cf26371c5beee1e905a33e4c6fc343bb490bb43a73334960f0c13df7d372841949a46d7dc5b6c0a404e6648828104717274518a8ff905a0ae15ad SHA512 ed386e01869cfac3d12881ddb4ae0258bb02e1d4a919a82405dbedce77406c04269883b6e1456dbad52551217307a7baebbb355a699168b77810263f5e357895
diff --git a/sci-mathematics/scilab-bin/scilab-bin-2023.1.0.ebuild b/sci-mathematics/scilab-bin/scilab-bin-2023.1.0.ebuild
new file mode 100644
index 000000000..83d189b8a
--- /dev/null
+++ b/sci-mathematics/scilab-bin/scilab-bin-2023.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+MY_PN="${PN//-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Scientific software package for numerical computations"
+HOMEPAGE="https://www.scilab.org/"
+SRC_URI="https://www.scilab.org/download/${PV}/${MY_P}.bin.x86_64-linux-gnu.tar.xz"
+S="${WORKDIR}/${P//-bin}"
+
+LICENSE="GPL-2 Apache-2.0 sun-bcla-jhall jing MPL-1.0 MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+# Bundled dependencies not packaged in ::gentoo
+# sci-libs/hdf5[cxx]:0/9
+# libgluegen.so (in ::sci)
+# libjogl_desktop.so (in ::sci)
+# libOpenXLSX.so (in ::sci)
+#
+# Bundled dependencies in ::gentoo
+# dev-lang/tcl
+# dev-libs/openssl:0/1.1
+# dev-libs/newt
+# dev-libs/libpcre
+# net-misc/curl
+# sci-libs/amd
+# sci-libs/arpack
+# sci-libs/camd
+# sci-libs/ccolamd
+# sci-libs/cholmod
+# sci-libs/colamd
+# sci-libs/fftw:3.0/3
+# sci-libs/lapack
+# sci-libs/matio
+# sci-libs/openblas
+# sci-libs/umfpack
+
+RDEPEND="
+ sys-libs/ncurses-compat
+ virtual/jre:1.8
+"
+
+QA_PREBUILT=( "opt/${MY_PN}/*" )
+
+src_prepare() {
+ default
+ local SCILAB_HOME="/opt/${MY_PN}"
+ # fix the .pc file to reflect the dirs where we are installing stuff
+ sed -i -e "/^prefix=/c prefix=${SCILAB_HOME}" lib/pkgconfig/scilab.pc || die
+
+ # move appdata to metainfo
+ mv share/appdata share/metainfo || die
+}
+
+src_install() {
+ local SCILAB_HOME="/opt/${MY_PN}"
+ dodir "${SCILAB_HOME}"
+
+ # make convenience symlinks in PATH
+ for file in bin/*; do
+ dosym "../${MY_PN}/${file}" "/opt/${file}"
+ done
+
+ # copy all the things
+ cp -r "${S}/"* "${ED}/${SCILAB_HOME}" || die
+
+ # move out dekstop, icons etc
+ dodir /usr/share
+ mv "${ED}/${SCILAB_HOME}/share/"{metainfo,applications,icons,locale,mime} "${ED}/usr/share/" || die
+ dodir /usr/lib64/pkgconfig
+ mv "${ED}/${SCILAB_HOME}/lib/pkgconfig/scilab.pc" "${ED}/usr/lib64/pkgconfig/" || die
+}