aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-elmergrid/elmer-elmergrid-9999.ebuild')
-rw-r--r--sci-misc/elmer-elmergrid/elmer-elmergrid-9999.ebuild46
1 files changed, 21 insertions, 25 deletions
diff --git a/sci-misc/elmer-elmergrid/elmer-elmergrid-9999.ebuild b/sci-misc/elmer-elmergrid/elmer-elmergrid-9999.ebuild
index 67549e910..fe17b7903 100644
--- a/sci-misc/elmer-elmergrid/elmer-elmergrid-9999.ebuild
+++ b/sci-misc/elmer-elmergrid/elmer-elmergrid-9999.ebuild
@@ -1,48 +1,44 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit autotools eutils subversion
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils subversion
ELMER_ROOT="elmerfem"
MY_PN=${PN/elmer-/}
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, elmergrid"
+DESCRIPTION="Finite element programs, libraries, and visualization tools - elmergrid"
HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
SRC_URI=""
-RESTRICT="mirror"
ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
ESVN_PROJECT="${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS=""
IUSE="debug"
-DEPEND="sci-libs/matc
- sys-libs/glibc"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PV}/elmergrid"
+RDEPEND="
+ sci-libs/matc
+ sci-libs/metis"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/elmergrid"
src_prepare() {
- #unpack ${A}
- cd "${S}"
- # configure must be executable
- #chmod +x configure
- eautoreconf
+ subversion_src_prepare
+ autotools-utils_src_prepare
}
src_configure() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- myconf="$myconf --with-matc"
- econf $myconf || die "econf failed"
+ local myeconfargs=(
+ $(use_with debug)
+ --with-metis-libs="${EPREFIX}"/usr/$(get_libdir)
+ --with-metis-include="${EPREFIX}"/usr/include/metis
+ )
+ autotools-utils_src_configure
}