aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-front/elmer-front-9999.ebuild')
-rw-r--r--sci-misc/elmer-front/elmer-front-9999.ebuild53
1 files changed, 25 insertions, 28 deletions
diff --git a/sci-misc/elmer-front/elmer-front-9999.ebuild b/sci-misc/elmer-front/elmer-front-9999.ebuild
index 054841075..7754b8aa4 100644
--- a/sci-misc/elmer-front/elmer-front-9999.ebuild
+++ b/sci-misc/elmer-front/elmer-front-9999.ebuild
@@ -1,54 +1,51 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit autotools eutils subversion
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils multilib subversion
ELMER_ROOT="elmerfem"
MY_PN=${PN/elmer-/}
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, elmer frontend"
+DESCRIPTION="Finite element programs, libraries, and visualization tools - elmer frontend"
HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
SRC_URI=""
-RESTRICT="mirror"
ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
ESVN_PROJECT="${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X debug"
-DEPEND="dev-lang/tcl
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-lang/tcl
dev-lang/tk
sci-libs/matc
sci-libs/elmer-eio
virtual/opengl"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/front"
-S="${WORKDIR}/${PV}/front"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0_p4651-tcltk8.6.patch
+ "${FILESDIR}"/${PN}-6.0_p4651-underlinking.patch
+ "${FILESDIR}"/${PN}-6.0_p4651-out-of-source.patch
+)
src_prepare() {
- #unpack ${A}
- cd "${S}"
- # configure must be executable
- #chmod +x configure
- epatch ${FILESDIR}/elmer-front-Makefile-install.patch
- eautoreconf
+ subversion_src_prepare
+ autotools-utils_src_prepare
}
src_configure() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- myconf="${myconf} --with-eioc --with-matc --with-tcltk"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- econf $myconf \
- $(use_with X x) \
- || die "econf failed"
+ local myeconfargs=(
+ --with-eioc --with-matc --with-tcltk --with-x
+ )
+ autotools-utils_src_configure
}