aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-meshgen2d/elmer-meshgen2d-6.0_p4651.ebuild')
-rw-r--r--sci-misc/elmer-meshgen2d/elmer-meshgen2d-6.0_p4651.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-misc/elmer-meshgen2d/elmer-meshgen2d-6.0_p4651.ebuild b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-6.0_p4651.ebuild
new file mode 100644
index 000000000..e8ec49efe
--- /dev/null
+++ b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-6.0_p4651.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Finite element programs, libraries, and visualization tools - meshgen2d"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV%_p*}/${MY_PN}/?view=tar&pathrev=4651 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+S="${WORKDIR}/meshgen2d"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-oof.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with debug)
+ )
+ autotools-utils_src_configure
+}