aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/finomaton/finomaton-1.0.ebuild')
-rw-r--r--sci-misc/finomaton/finomaton-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-misc/finomaton/finomaton-1.0.ebuild b/sci-misc/finomaton/finomaton-1.0.ebuild
new file mode 100644
index 000000000..e51d488ba
--- /dev/null
+++ b/sci-misc/finomaton/finomaton-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# N.B. this is from CTAN
+
+DESCRIPTION="Simple tcl/tk script to draw finite state automata"
+HOMEPAGE="http://stud4.tuwien.ac.at/~e0225855/finomaton/finomaton.html"
+SRC_URI="http://stud4.tuwien.ac.at/~e0225855/finomaton/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="examples"
+
+# script only
+DEPEND=""
+# tetex for metapost
+RDEPEND="app-text/tetex
+ >=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3"
+
+src_install() {
+ dobin finomaton.tcl
+ dodoc ChangeLog TODO README
+ if use examples ; then
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ for f in examples ; do
+ doins ${f}
+ done
+ fi
+}