aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/gambit/gambit-0.2010.09.01.ebuild')
-rw-r--r--sci-misc/gambit/gambit-0.2010.09.01.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-misc/gambit/gambit-0.2010.09.01.ebuild b/sci-misc/gambit/gambit-0.2010.09.01.ebuild
new file mode 100644
index 000000000..132a798a2
--- /dev/null
+++ b/sci-misc/gambit/gambit-0.2010.09.01.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Gambit: Software Tools for Game Theory"
+
+HOMEPAGE="http://www.gambit-project.org/doc/index.html"
+
+SRC_URI="mirror://sourceforge/gambit/${P}.tar.gz
+ "
+ #http://econweb.tamu.edu/gambit/doc/${PN}-manual-${PV}.pdf
+ #http://econweb.tamu.edu/gambit/doc/${PN}-manual-${PV}.tar.gz
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+#IUSE="wxwindows"
+IUSE="X"
+
+DEPEND="X? ( >=x11-libs/wxGTK-2.6
+ =x11-libs/gtk+-1.2* )
+ "
+
+RDEPEND=""
+
+src_compile() {
+ # disable
+ local myconf
+ if use amd64
+ then
+ myconf='--disable-enumpoly'
+ fi
+ econf "${myconf}" \
+ "$(use_enable X gui)" ||die
+ emake ||die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install ||die
+ dodoc NEWS README* AUTHORS ChangeLog
+}
+