aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/praat/praat-5.1.00.ebuild')
-rw-r--r--sci-misc/praat/praat-5.1.00.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-misc/praat/praat-5.1.00.ebuild b/sci-misc/praat/praat-5.1.00.ebuild
new file mode 100644
index 000000000..25ae8d384
--- /dev/null
+++ b/sci-misc/praat/praat-5.1.00.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator
+# FIXME: for versions with last part < 10 pad with zeroes
+# e.g 4 => 4000, 5.1 => 5100, 5.2.7 => 5207.
+MY_PV=$(delete_all_version_separators)
+
+DESCRIPTION="Speech analysis and synthesis"
+SRC_URI="http://www.fon.hum.uva.nl/praat/${PN}${MY_PV}_sources.tar.gz"
+HOMEPAGE="http://www.fon.hum.uva.nl/praat/"
+DEPEND="|| ( ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXp
+ )
+ virtual/x11
+ )
+ x11-libs/openmotif"
+RDEPEND="${DEPEND}"
+KEYWORDS="~amd64"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+S="${WORKDIR}/sources_${MY_PV}"
+
+src_compile() {
+ # TODO: following line should be updated for non-linux etc. builds
+ # (Flammie does not have testing equipment)
+ cp "${S}/makefiles/makefile.defs.linux.dynamic" "${S}/makefile.defs"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin praat
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins test/*
+ dodir /usr/share/${PN}/texio
+ insinto /usr/share/${PN}/texio
+ doins test/texio/*
+ dodir /usr/share/${PN}/logisticRegression
+ insinto /usr/share/${PN}/logisticRegression
+ doins test/logisticRegression/*
+}
+