aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/salome-geom/salome-geom-3.2.6.ebuild')
-rw-r--r--sci-misc/salome-geom/salome-geom-3.2.6.ebuild21
1 files changed, 5 insertions, 16 deletions
diff --git a/sci-misc/salome-geom/salome-geom-3.2.6.ebuild b/sci-misc/salome-geom/salome-geom-3.2.6.ebuild
index 27cb9c58d..8670c824d 100644
--- a/sci-misc/salome-geom/salome-geom-3.2.6.ebuild
+++ b/sci-misc/salome-geom/salome-geom-3.2.6.ebuild
@@ -1,26 +1,25 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-
+# $Header: $
inherit autotools distutils eutils flag-o-matic toolchain-funcs versionator python multilib
DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. GEOM component"
HOMEPAGE="http://www.salome-platform.org"
-SRC_URI="salome-3.2.6.tar.gz"
+SRC_URI="http://files.opencascade.com/Salome${PV}/src${PV}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc opengl mpi debug"
-RESTRICT="fetch"
RDEPEND="opengl? ( virtual/opengl )
mpi? ( sys-cluster/mpich2 )
debug? ( dev-util/cppunit )"
DEPEND="${RDEPEND}
- >=sci-misc/salome-kernel-3.2.6
- >=sci-misc/salome-gui-3.2.6
+ >=sci-misc/salome-kernel-${PV}
+ >=sci-misc/salome-gui-${PV}
<=dev-python/omniorbpy-2.6
<=net-misc/omniORB-4.1"
@@ -32,16 +31,6 @@ INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
GEOM_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
export OPENPBS="/usr"
-
-pkg_nofetch()
-{
- einfo "You have to download manually the source code. You can download it from :"
- einfo " http://www.salome-platform.org/download/dl326"
- einfo ""
- einfo "Put the archive in the \"/usr/portage/distfile\" directory and rename it \"salome-3.2.6.tar.gz\""
-}
-
-
src_unpack()
{
python_version
@@ -137,7 +126,7 @@ src_install()
insinto "${INSTALL_DIR}"
doins -r adm_local
if use doc ; then
- dodoc INSTALL LICENCE
+ dodoc INSTALL
fi
}