aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/salome-gui/salome-gui-5.1.3.ebuild')
-rw-r--r--sci-misc/salome-gui/salome-gui-5.1.3.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/sci-misc/salome-gui/salome-gui-5.1.3.ebuild b/sci-misc/salome-gui/salome-gui-5.1.3.ebuild
index 01195511b..21cb5c90c 100644
--- a/sci-misc/salome-gui/salome-gui-5.1.3.ebuild
+++ b/sci-misc/salome-gui/salome-gui-5.1.3.ebuild
@@ -5,11 +5,11 @@
EAPI=2
PYTHON_DEPEND="2:2.4"
-inherit distutils eutils flag-o-matic
+inherit eutils flag-o-matic python
DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. GUI component"
HOMEPAGE="http://www.salome-platform.org"
-SRC_URI="http://www.stasyan.com/devel/distfiles/src${PV}.tar.gz"
+SRC_URI="http://files.opencascade.com/Salome/Salome${PV}/src${PV}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
@@ -28,7 +28,7 @@ RDEPEND="opengl? ( virtual/opengl )
>=x11-libs/qt-opengl-4.5.2
>=x11-libs/qwt-5.2
>=dev-python/PyQt4-4.5.4
- >=sci-libs/vtk-5.0[python]
+ >=sci-libs/vtk-5.0[python,mpi]
>=sci-libs/opencascade-6.3
app-text/dgs"
@@ -40,19 +40,16 @@ DEPEND="${RDEPEND}
dev-libs/libxml2"
MODULE_NAME="GUI"
-MY_S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
+S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
GUI_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
pkg_setup() {
- PYVER=$(python_get_version)
- [[ ${PYVER} > 2.4 ]] && \
+ [[ $(python_get_version) > 2.4 ]] && \
ewarn "Python 2.4 is highly recommended for Salome..."
}
src_prepare() {
- cd "${MY_S}"
-
epatch "${FILESDIR}"/${P}-qt4-path.patch
rm -r -f autom4te.cache
@@ -61,8 +58,6 @@ src_prepare() {
}
src_configure() {
- cd "${MY_S}"
-
local vtk_suffix=""
has_version ">=sci-libs/vtk-5.0" && vtk_suffix="-5.0"
@@ -74,8 +69,8 @@ src_configure() {
--docdir=${INSTALL_DIR}/doc/salome \
--infodir=${INSTALL_DIR}/share/info \
--libdir=${INSTALL_DIR}/$(get_libdir)/salome \
- --with-python-site=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
- --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
+ --with-python-site=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
+ --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
--with-qt=/usr \
--with-qwt=/usr \
--with-qwt_inc=/usr/include/qwt5 \
@@ -90,14 +85,10 @@ src_configure() {
}
src_compile() {
- cd "${MY_S}"
-
MAKEOPTS="-j1" emake || die "emake failed"
}
src_install() {
- cd "${MY_S}"
-
emake DESTDIR="${D}" install || die "emake install failed"
use amd64 && dosym ${INSTALL_DIR}/lib64 ${INSTALL_DIR}/lib
@@ -105,9 +96,11 @@ src_install() {
echo "${MODULE_NAME}_ROOT_DIR=${INSTALL_DIR}" > ./90${P}
echo "LDPATH=${INSTALL_DIR}/$(get_libdir)/salome" >> ./90${P}
echo "PATH=${INSTALL_DIR}/bin/salome" >> ./90${P}
- echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome" >> ./90${P}
+ echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome" >> ./90${P}
doenvd 90${P}
- rm adm_local/Makefile
+ rm adm_local/Makefile adm_local/unix/Makefile adm_local/cmake_files/Makefile \
+ adm_local/unix/config_files/Makefile
+
insinto "${INSTALL_DIR}"
doins -r adm_local
use doc && dodoc AUTHORS INSTALL NEWS README