aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/salome-pycalculator/Changelog7
-rw-r--r--sci-misc/salome-pycalculator/Manifest4
-rw-r--r--sci-misc/salome-pycalculator/files/salome-pycalculator-3.2.6.patch11
-rw-r--r--sci-misc/salome-pycalculator/salome-pycalculator-3.2.6.ebuild149
4 files changed, 171 insertions, 0 deletions
diff --git a/sci-misc/salome-pycalculator/Changelog b/sci-misc/salome-pycalculator/Changelog
new file mode 100644
index 000000000..a2647e405
--- /dev/null
+++ b/sci-misc/salome-pycalculator/Changelog
@@ -0,0 +1,7 @@
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+21 May 2008; Daniel Tourde <daniel.tourde@caelae.se>
+ Initial import.
+ +salome-pycalculator-3.2.6.ebuild, +salome-pycalculator-3.2.6.patch
+ A major thank to Francois Dorin <f.dorin@free.fr>, Jon Hood <squinky86@gmail.com>, Dewald Pietersen <dewald.pieterse@gmail.com>, <etienne.lorriaux@gmail.com> and Richard Westwell <garlicbread@ntlworld.com> for their respective contributions and feedback. Without you guys, the Salome ebuilds would not exist today. Thanks!
+ See bug #155974 for more info \ No newline at end of file
diff --git a/sci-misc/salome-pycalculator/Manifest b/sci-misc/salome-pycalculator/Manifest
new file mode 100644
index 000000000..6c038d429
--- /dev/null
+++ b/sci-misc/salome-pycalculator/Manifest
@@ -0,0 +1,4 @@
+AUX salome-pycalculator-3.2.6.patch 535 RMD160 5cf0de1ecd17f58e84115efd2178118565f71e36 SHA1 f66595c14bdf6a73b0e91479e267b73a64a2101a SHA256 6e8f10d9db73baa0a4939b8b3403e66dba397949f38f0495ab62600a7bc9c12a
+DIST salome-3.2.6.tar.gz 88763725 RMD160 0a0b77aa538832265416605bf502df9e790b45b7 SHA1 e4736b8431d3a4f43541e09eed861f88a2a2f439 SHA256 1f4ae59538675242b179fa2af9bf9adeffe87c8d80d3e6798bca03eafc0bb258
+EBUILD salome-pycalculator-3.2.6.ebuild 4264 RMD160 843c28dc444c7a699f88cea3e73973f6c0533192 SHA1 2c52cebf008d42ea43c33e16873a7534fccec284 SHA256 abcc5885321c596cee646d81f8abb10edb053b6c45e8eda16e2a54f0e1ffcee8
+MISC Changelog 580 RMD160 a5da724604a1781b2d9bab8ee4ef95ec07bf1f8a SHA1 636aaac36c1e58bf8c496c0bdbdf7083fa2ef120 SHA256 124bfc604c0bdc0e75e7fbe71e0ca112230729cc9d29ba98dce0e17966ae6ae6
diff --git a/sci-misc/salome-pycalculator/files/salome-pycalculator-3.2.6.patch b/sci-misc/salome-pycalculator/files/salome-pycalculator-3.2.6.patch
new file mode 100644
index 000000000..9897907f4
--- /dev/null
+++ b/sci-misc/salome-pycalculator/files/salome-pycalculator-3.2.6.patch
@@ -0,0 +1,11 @@
+--- ./PYCALCULATOR_SRC_3.2.6/build_configure.org 2007-04-24 18:41:04.000000000 +0200
++++ ./PYCALCULATOR_SRC_3.2.6/build_configure 2008-02-21 10:20:34.000000000 +0100
+@@ -109,7 +109,7 @@
+
+ # make a link allowing AC_OUTPUT to find the salome_adm/.../*.in files
+ echo "" >> configure.in_tmp1
+-echo 'ln -fs ${KERNEL_ROOT_DIR}/salome_adm ${ROOT_SRCDIR}/.' >> configure.in_tmp1
++echo 'cp -prf ${KERNEL_ROOT_DIR}/salome_adm ${ROOT_SRCDIR}/.' >> configure.in_tmp1
+
+ echo "" >> configure.in_tmp1
+ echo "AC_OUTPUT([ \\" >> configure.in_tmp1
diff --git a/sci-misc/salome-pycalculator/salome-pycalculator-3.2.6.ebuild b/sci-misc/salome-pycalculator/salome-pycalculator-3.2.6.ebuild
new file mode 100644
index 000000000..e81c93345
--- /dev/null
+++ b/sci-misc/salome-pycalculator/salome-pycalculator-3.2.6.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+inherit autotools distutils eutils flag-o-matic toolchain-funcs versionator python multilib
+
+DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. PYCALCULATOR Component"
+HOMEPAGE="http://www.salome-platform.org"
+SRC_URI="salome-3.2.6.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc mpi debug"
+RESTRICT="fetch"
+
+RDEPEND="mpi? ( sys-cluster/mpich2 )
+ debug? ( dev-util/cppunit )"
+
+DEPEND="${RDEPEND}
+ >=sci-misc/salome-kernel-3.2.6
+ >=sci-misc/salome-med-3.2.6
+ >=sci-misc/salome-component-3.2.6
+ <=dev-python/omniorbpy-2.6
+ <=net-misc/omniORB-4.1"
+
+# Note that Corba is apparently not optional in this module
+
+MODULE_NAME="PYCALCULATOR"
+MY_S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
+INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
+PYCALCULATOR_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
+export OPENPBS="/usr"
+
+
+pkg_nofetch()
+{
+ einfo "You have to download manually the source code. You can download it from :"
+ einfo " http://www.salome-platform.org/download/dl326"
+ einfo ""
+ einfo "Put the archive in the \"/usr/portage/distfile\" directory and rename it \"salome-3.2.6.tar.gz\""
+}
+
+
+src_unpack()
+{
+ python_version
+ distutils_python_version
+ ewarn "Python 2.4 is highly recommended for Salome..."
+
+ if ! built_with_use sci-libs/vtk python ; then
+ die "You must rebuild sci-libs/vtk with python USE flag"
+ fi
+
+ unpack ${A}
+ cd "${MY_S}"
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+
+src_compile()
+{
+ local myconf=""
+ cd "${MY_S}"
+ rm -r -f autom4te.cache
+ ./build_configure
+
+ # CXXFLAGS are slightly modified to allow the compilation of
+ # salome-pycalculator with OpenCascade and gcc-4.1.x
+ if version_is_at_least "4.1" $(gcc-version) ; then
+ append-flags -ffriend-injection -fpermissive
+ fi
+
+ # If vtk-5.O is used, include directory is named vtk-5.0 and not vtk
+ if has_version ">=sci-libs/vtk-5.0" ; then
+ einfo "vtk version 5 detected"
+ append-flags -I/usr/include/vtk-5.0
+ else
+ einfo "vtk version 4 or prior detected"
+ fi
+
+ # Compiler and linker flags
+ if use amd64 ; then
+ append-flags -m64
+ fi
+
+ # Specifying --without-<flag> for mpi / mpich
+ # has the same effect as turning it on
+ # so we just ommit it if it's not required to turn it off
+ if use mpi; then
+ myconf="${myconf} --with-mpi --with-mpich"
+ fi
+
+ # Configuration
+ econf --prefix=${INSTALL_DIR} \
+ --datadir=${INSTALL_DIR}/share/salome \
+ --docdir=${INSTALL_DIR}/doc/salome \
+ --infodir=${INSTALL_DIR}/share/info \
+ --libdir=${INSTALL_DIR}/$(get_libdir)/salome \
+ --with-python-site=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
+ --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
+ ${myconf} \
+ $(use_enable debug ) \
+ $(use_enable !debug production ) \
+ $(use_with debug cppunit /usr ) \
+ || die "configuration failed"
+
+ # Compilation
+ MAKEOPTS="-j1" emake || die "Compilation failed"
+}
+
+
+src_install()
+{
+ cd "${MY_S}"
+
+ # Installation
+ emake prefix="${D}/${INSTALL_DIR}" \
+ docdir="${D}/${INSTALL_DIR}/doc/salome" \
+ infodir="${D}/${INSTALL_DIR}/share/info" \
+ datadir="${D}/${INSTALL_DIR}/share/salome" \
+ libdir="${D}/${INSTALL_DIR}/$(get_libdir)/salome" \
+ PYTHON_SITE_INSTALL="${D}/${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome" \
+ sharedpydir="${D}/${INSTALL_DIR}/usr/lib/python${PYVER}/site-packages/salome/shared_modules" install \
+ || die "emake install failed"
+
+ if use amd64 ; then
+ dosym ${INSTALL_DIR}/lib64 ${INSTALL_DIR}/lib
+ fi
+
+ echo "${MODULE_NAME}_ROOT_DIR=${INSTALL_DIR}" > ./90${P}
+ echo "LDPATH=${INSTALL_DIR}/$(get_libdir)/salome" >> ./90${P}
+ echo "PATH=${INSTALL_DIR}/bin/salome" >> ./90${P}
+ echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome" >> ./90${P}
+ doenvd 90${P}
+ rm adm_local/Makefile adm_local/unix/make_commence adm_local/unix/make_conclude adm_local/unix/make_omniorb
+ insinto "${INSTALL_DIR}"
+ doins -r adm_local
+ if use doc ; then
+ dodoc INSTALL
+ fi
+}
+
+
+pkg_postinst() {
+ elog "Run \`env-update && source /etc/profile\`"
+ elog "now to set up the correct paths."
+ elog ""
+} \ No newline at end of file