aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/stanford-parser/ChangeLog6
-rw-r--r--sci-misc/stanford-parser/metadata.xml8
-rw-r--r--sci-misc/stanford-parser/stanford-parser-1.6.ebuild12
3 files changed, 15 insertions, 11 deletions
diff --git a/sci-misc/stanford-parser/ChangeLog b/sci-misc/stanford-parser/ChangeLog
index d958f9f7d..6b1994c7c 100644
--- a/sci-misc/stanford-parser/ChangeLog
+++ b/sci-misc/stanford-parser/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-misc/stanford-parser
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 12 Nov 2014; Justin Lecher <jlec@gentoo.org> stanford-parser-1.6.ebuild,
+ metadata.xml:
+ Bump to EAPI=5
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/stanford-parser/metadata.xml b/sci-misc/stanford-parser/metadata.xml
index b1fe96c54..e72137569 100644
--- a/sci-misc/stanford-parser/metadata.xml
+++ b/sci-misc/stanford-parser/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>flammie@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <maintainer>
+ <email>flammie@gentoo.org</email>
+ </maintainer>
+ <longdescription>
Stanford parser is a natural language parser implemented in Java and using
statistical methods. It includes PCFG and dependency parsers.
</longdescription>
diff --git a/sci-misc/stanford-parser/stanford-parser-1.6.ebuild b/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
index 7793e3951..3b29f4262 100644
--- a/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
+++ b/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
@@ -2,19 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
+
JAVA_PKG_IUSE="doc source"
inherit eutils java-pkg-2 java-ant-2
MY_PV=2007-08-19
MY_P=${PN}-${MY_PV}
+
DESCRIPTION="Stanfords statistical natural language parsers"
HOMEPAGE="http://www-nlp.stanford.edu/software/"
SRC_URI="http://www-nlp.stanford.edu/software/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
IUSE="${IUSE}"
COMMON_DEP=""
@@ -24,6 +26,7 @@ RDEPEND=">=virtual/jre-1.5
${COMMON_DEP}"
S="${WORKDIR}/${MY_P}"
+
EANT_BUILD_TARGET="compile"
src_install() {
@@ -35,11 +38,8 @@ src_install() {
java-pkg_dosrc src
fi
dodoc README.txt README_dependencies.txt cedict_readme.txt
- dodir /usr/share/${PN}
insinto /usr/share/${PN}
- for f in *ser.gz ; do
- doins ${f}
- done
+ doins *ser.gz
java-pkg_dolauncher stanford-lexparser --java_args -Xmx200m --main edu.stanford.nlp.parser.lexparser.LexicalizedParser
java-pkg_dolauncher stanford-lexparser-gui --java_args "-server -Xmx600m" --main edu.stanford.nlp.parser.ui.Parser
}