aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/hoppet/hoppet-1.2.0.ebuild')
-rw-r--r--sci-physics/hoppet/hoppet-1.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-physics/hoppet/hoppet-1.2.0.ebuild b/sci-physics/hoppet/hoppet-1.2.0.ebuild
new file mode 100644
index 000000000..337881026
--- /dev/null
+++ b/sci-physics/hoppet/hoppet-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2
+
+DESCRIPTION="Higher Order Perturbative Parton Evolution Toolkit"
+HOMEPAGE="
+ https://hoppet.hepforge.org/
+ https://github.com/gavinsalam/hoppet
+"
+SRC_URI="https://hoppet.hepforge.org/downloads/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+
+
+src_configure() {
+ default
+ # own custom configure
+ ./configure --prefix="${EPREFIX}"/usr FFLAGS="${FFLAGS} -fPIC" || die
+}
+
+src_install() {
+ # Fix install to ED
+ sed -i "s#scripts/install-sh hoppet-config#\##g" Makefile || die
+ sed -i "s#/usr/lib/libhoppet#${ED}/usr/$(get_libdir)/libhoppet#g" src/Makefile || die
+ sed -i "s#/usr/include/hoppet#${ED}/usr/include/hoppet#g" src/Makefile || die
+ emake install
+ emake install-mod
+ dobin hoppet-config
+ find "${ED}" -name '*.la' -delete || die
+}