aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/pyhepmc/pyhepmc-2.11.0.ebuild')
-rw-r--r--sci-physics/pyhepmc/pyhepmc-2.11.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-physics/pyhepmc/pyhepmc-2.11.0.ebuild b/sci-physics/pyhepmc/pyhepmc-2.11.0.ebuild
new file mode 100644
index 000000000..c28b094bb
--- /dev/null
+++ b/sci-physics/pyhepmc/pyhepmc-2.11.0.ebuild
@@ -0,0 +1,20 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Pythonic wrapper for the HepMC3 C++ library."
+HOMEPAGE="https://github.com/scikit-hep/pyhepmc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-build/cmake
+"