aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/qcdloop/qcdloop-2.0.5.ebuild')
-rw-r--r--sci-physics/qcdloop/qcdloop-2.0.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-physics/qcdloop/qcdloop-2.0.5.ebuild b/sci-physics/qcdloop/qcdloop-2.0.5.ebuild
new file mode 100644
index 000000000..672957c56
--- /dev/null
+++ b/sci-physics/qcdloop/qcdloop-2.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake fortran-2
+
+DESCRIPTION="An object-oriented one-loop scalar Feynman integrals framework"
+HOMEPAGE="https://qcdloop.web.cern.ch/qcdloop/"
+SRC_URI="https://github.com/scarrazza/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cxx.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ cmake_src_configure
+}