aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/spheno/files/spheno-3.3.8-gfortran.patch')
-rw-r--r--sci-physics/spheno/files/spheno-3.3.8-gfortran.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch b/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
new file mode 100644
index 000000000..8f6fa7e19
--- /dev/null
+++ b/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
@@ -0,0 +1,32 @@
+--- a/src/Makefile 2022-07-20 11:47:44.078639381 +0200
++++ b/src/Makefile 2022-07-24 02:16:38.972041809 +0200
+@@ -9,10 +9,11 @@
+ # options for various compilers
+ #
+
+-# Intels ifort, default in optimized mode
+-F90 = ifort
+-comp = -c -O -module ${Mdir} -I${InDir}
+-LFlagsB = -O
++
++# gentoo toolchain
++F90 = ${F90}
++comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
++LFlagsB = -O ${LDFLAGS}
+
+ # Intels ifort, debug modus
+ ifeq (${F90},ifortg)
+@@ -70,11 +71,11 @@
+ #
+ .f90.a:
+ ${F90} ${comp} $<
+- ar -ruc $@ $*.o
++ $(AR) -ruc $@ $*.o
+ rm -f $*.o
+ .F90.a:
+ ${F90} ${comp} ${PreDef} $<
+- ar -ruc $@ $*.o
++ $(AR) -ruc $@ $*.o
+ rm -f $*.o
+ .f90.o:
+ ${F90} ${comp} $<