aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/spheno/files/spheno-4.0.5-gfortran.patch')
-rw-r--r--sci-physics/spheno/files/spheno-4.0.5-gfortran.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch b/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch
new file mode 100644
index 000000000..1abf36367
--- /dev/null
+++ b/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch
@@ -0,0 +1,29 @@
+--- a/src/Makefile 2023-05-04 12:33:44.804394098 +0200
++++ b/src/Makefile 2023-05-04 12:34:37.023776033 +0200
+@@ -21,9 +21,9 @@
+ #
+
+ # Intels ifort, default in optimized mode
+-F90 = ifort
+-comp = -c -O -module ${Mdir} -I${InDir}
+-LFlagsB = -O
++F90 = ${F90}
++comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
++LFlagsB = -O ${LDFLAGS}
+
+ # Intels ifort, debug modus
+ ifeq (${F90},ifortg)
+@@ -81,11 +81,11 @@
+ #
+ .f90.a:
+ ${F90} ${comp} $<
+- ar ${linker} $@ $*.o
++ $(AR) ${linker} $@ $*.o
+ rm -f $*.o
+ .F90.a:
+ ${F90} ${comp} ${PreDef} $<
+- ar ${linker} $@ $*.o
++ $(AR) ${linker} $@ $*.o
+ rm -f $*.o
+ .f90.o:
+ ${F90} ${comp} $<