aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/spheno')
-rw-r--r--sci-physics/spheno/Manifest2
-rw-r--r--sci-physics/spheno/files/spheno-3.3.8-gfortran.patch32
-rw-r--r--sci-physics/spheno/files/spheno-4.0.5-gfortran.patch29
-rw-r--r--sci-physics/spheno/metadata.xml19
-rw-r--r--sci-physics/spheno/spheno-3.3.8-r1.ebuild39
-rw-r--r--sci-physics/spheno/spheno-4.0.5.ebuild39
6 files changed, 160 insertions, 0 deletions
diff --git a/sci-physics/spheno/Manifest b/sci-physics/spheno/Manifest
new file mode 100644
index 000000000..5db72217b
--- /dev/null
+++ b/sci-physics/spheno/Manifest
@@ -0,0 +1,2 @@
+DIST spheno-3.3.8.tar.gz 1415645 BLAKE2B 830cdbcd8f213f0de0cd0b72455d5919e390069f097bca5a0cabdbfb77ec21549c9455139ff960a0cdbd425368805c1f2d11384c240a8e82f66e33864f4fce7b SHA512 e6c923586eae198f62121e0410f9f1f87e7badfd58d90e3b5f600e8364ea054dfb8b58c1c39d74ec6067112fa6cad727797230bce6cfc6040e2bf4c6d01b0eae
+DIST spheno-4.0.5.tar.gz 1587855 BLAKE2B d3cb92740be416934a928147d980e180be623dbbfeac7a1b0b16e7e4a36d2b3088e455b5348f6e65cfa2ac8d90286c0b65a81498527419ed4eaa42622651408b SHA512 387099c3d9c9c7baf4a5da6d46b819d53dc703f72cc3a73fac7c2e63b66623e328294ac131e128253002ab03a81e96c686702ac90a58479ae573f228d3a51379
diff --git a/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch b/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
new file mode 100644
index 000000000..8f6fa7e19
--- /dev/null
+++ b/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
@@ -0,0 +1,32 @@
+--- a/src/Makefile 2022-07-20 11:47:44.078639381 +0200
++++ b/src/Makefile 2022-07-24 02:16:38.972041809 +0200
+@@ -9,10 +9,11 @@
+ # options for various compilers
+ #
+
+-# Intels ifort, default in optimized mode
+-F90 = ifort
+-comp = -c -O -module ${Mdir} -I${InDir}
+-LFlagsB = -O
++
++# gentoo toolchain
++F90 = ${F90}
++comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
++LFlagsB = -O ${LDFLAGS}
+
+ # Intels ifort, debug modus
+ ifeq (${F90},ifortg)
+@@ -70,11 +71,11 @@
+ #
+ .f90.a:
+ ${F90} ${comp} $<
+- ar -ruc $@ $*.o
++ $(AR) -ruc $@ $*.o
+ rm -f $*.o
+ .F90.a:
+ ${F90} ${comp} ${PreDef} $<
+- ar -ruc $@ $*.o
++ $(AR) -ruc $@ $*.o
+ rm -f $*.o
+ .f90.o:
+ ${F90} ${comp} $<
diff --git a/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch b/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch
new file mode 100644
index 000000000..1abf36367
--- /dev/null
+++ b/sci-physics/spheno/files/spheno-4.0.5-gfortran.patch
@@ -0,0 +1,29 @@
+--- a/src/Makefile 2023-05-04 12:33:44.804394098 +0200
++++ b/src/Makefile 2023-05-04 12:34:37.023776033 +0200
+@@ -21,9 +21,9 @@
+ #
+
+ # Intels ifort, default in optimized mode
+-F90 = ifort
+-comp = -c -O -module ${Mdir} -I${InDir}
+-LFlagsB = -O
++F90 = ${F90}
++comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
++LFlagsB = -O ${LDFLAGS}
+
+ # Intels ifort, debug modus
+ ifeq (${F90},ifortg)
+@@ -81,11 +81,11 @@
+ #
+ .f90.a:
+ ${F90} ${comp} $<
+- ar ${linker} $@ $*.o
++ $(AR) ${linker} $@ $*.o
+ rm -f $*.o
+ .F90.a:
+ ${F90} ${comp} ${PreDef} $<
+- ar ${linker} $@ $*.o
++ $(AR) ${linker} $@ $*.o
+ rm -f $*.o
+ .f90.o:
+ ${F90} ${comp} $<
diff --git a/sci-physics/spheno/metadata.xml b/sci-physics/spheno/metadata.xml
new file mode 100644
index 000000000..277841e1a
--- /dev/null
+++ b/sci-physics/spheno/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+The code calculates the SUSY spectrum using low energy data and a user supplied high scale model as input. The spectrum is used to calculate two- and three body decay modes of supersymmetric particle as well as of Higgs bosons. In addition the production cross sections for supersymmetric particle and Higgs bosons in e^+ e^- annihilation is calculated. Moreover, the branching of the decay $b \to s \gamma$, the SUSY contribution to anomalous magnetic moment of the muon as well as the SUSY contributions to the rho parameter due to sfermions are calculated. The code is written in F90 with an emphasis on easy generalisability. The structure is set such that complex phases as well as the extension to include the flavour structure can be done in a straight forward way. The 2-loop renormalization group equations as well as the one-loop finite corrections a la Bagger, Matchev, Pierce and Zhang are included. In addition the two-loop corrections to the neutral Higgs boson masses (a la Brignole, Degrassi, Slavich and Zwirner) and to the mu-parameter (a la Dedes and Slavich) are included. Starting with version 2.2.2 the SUSY Les Houches Accord is supported as well as the SPA conventions (for details see hep-ph/0511344).
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-physics/spheno/spheno-3.3.8-r1.ebuild b/sci-physics/spheno/spheno-3.3.8-r1.ebuild
new file mode 100644
index 000000000..7ed53c4c7
--- /dev/null
+++ b/sci-physics/spheno/spheno-3.3.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2
+
+MY_PN=SPheno
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="SPheno stands for S(upersymmetric) Pheno(menology)"
+HOMEPAGE="https://spheno.hepforge.org/"
+SRC_URI="https://spheno.hepforge.org/downloads/?f=${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="all-rights-reserved"
+RESTRICT="bindist mirror"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}"/${P}-gfortran.patch )
+
+src_compile() {
+ # single thread force needed since fortan mods depend on each other
+ emake -j1 F90="${FC}"
+}
+
+src_install() {
+ dobin bin/${MY_PN}
+ # convenience symlink since the package is lowercase but the default produced binary is uppercase
+ dosym ${MY_PN} /usr/bin/${PN}
+ dolib.a lib/lib${MY_PN}.a
+ mv include ${PN}
+ doheader -r ${PN}
+ dodoc doc/*
+ docinto examples
+ dodoc input/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
diff --git a/sci-physics/spheno/spheno-4.0.5.ebuild b/sci-physics/spheno/spheno-4.0.5.ebuild
new file mode 100644
index 000000000..7ed53c4c7
--- /dev/null
+++ b/sci-physics/spheno/spheno-4.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2
+
+MY_PN=SPheno
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="SPheno stands for S(upersymmetric) Pheno(menology)"
+HOMEPAGE="https://spheno.hepforge.org/"
+SRC_URI="https://spheno.hepforge.org/downloads/?f=${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="all-rights-reserved"
+RESTRICT="bindist mirror"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}"/${P}-gfortran.patch )
+
+src_compile() {
+ # single thread force needed since fortan mods depend on each other
+ emake -j1 F90="${FC}"
+}
+
+src_install() {
+ dobin bin/${MY_PN}
+ # convenience symlink since the package is lowercase but the default produced binary is uppercase
+ dosym ${MY_PN} /usr/bin/${PN}
+ dolib.a lib/lib${MY_PN}.a
+ mv include ${PN}
+ doheader -r ${PN}
+ dodoc doc/*
+ docinto examples
+ dodoc input/*
+ docompress -x /usr/share/doc/${PF}/examples
+}