aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/labplot/labplot-9999.ebuild')
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
index fbf5b0f11..8906e96de 100644
--- a/sci-visualization/labplot/labplot-9999.ebuild
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -1,19 +1,23 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit subversion kde4-base
+if [[ "${PV}" != "9999" ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ inherit kde4-base
+else
+ EGIT_REPO_URI="git://anongit.kde.org/labplot"
+ inherit kde4-base git-r3
+fi
MY_PN=LabPlot
MY_P=${MY_PN}-${PV}
DESCRIPTION="KDE data analysis and visualisation program"
-HOMEPAGE="http://labplot.sourceforge.net/"
-
-# SRC_URI="http://prdownloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
-ESVN_REPO_URI="https://labplot.svn.sourceforge.net/svnroot/labplot/2.0/"
+HOMEPAGE="https://edu.kde.org/applications/science/labplot/"
LICENSE="GPL-2"
SLOT="4"
@@ -21,17 +25,6 @@ KEYWORDS=""
IUSE=""
DEPEND="
- sci-libs/cdf
sci-libs/gsl
- sci-libs/hdf5
- sci-libs/liborigin
- sci-libs/netcdf
"
RDEPEND="$DEPEND"
-
-S=${WORKDIR}/${PN}
-
-PATCHES=( "${FILESDIR}/${P}-liborigin2.patch" )
-
-# this is partly hardwired in the build system :(
-CMAKE_BUILD_DIR=${S}/build