aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild')
-rw-r--r--sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild b/sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild
new file mode 100644
index 000000000..c88f89f6f
--- /dev/null
+++ b/sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild
@@ -0,0 +1,40 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+DESCRIPTION="The easybuild-framework package is the core of EasyBuild."
+HOMEPAGE="
+ https://easybuild.io/
+ https://github.com/easybuilders/easybuild-framework
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/easybuilders/easybuild-framework"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/archspec[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.2-test.patch
+)